7

A few days ago i noticed, that in new tab cursor doesn't set on address/search bar. Now I use ⌘+L combination to quickly switch, but it isn't comfortably for long time use.

Reflecting on the causes of such behavior , I found that the cursor stands on a search tab in the private tab.

What i tried to do to fix it:

  1. Set in general preferences parameter Open new tabs/windows with Empty page
  2. Turn off all extensions

I have OSX 10.11.5 with Safari 9.1.1 (and also i have the same problem on Safari Technology Preview 9.1.1)


Example:

Open new window enter image description here

Press combination cmd+T

enter image description here

But when I do same actions in private window cursor has already focused on address bar. enter image description here

  • Your question is a bit unclear - are you saying when you open a new tab you would like it to immediately focus on the address bar? – Tim Malone May 22 '16 at 7:25
  • @TimMalone Yes. I always open a new tab by cmd+T and start typing query or name of site. But now between this two process necessary use cmd+L. In private tab works well without additional actions. Maybe I knocked out some important settings or collied with issue in safari or osx. – Sanek Zhitnik May 22 '16 at 7:39
  • Have you tried going to the Safari menu? Menu Bar > History > Clear History... > Select 'Clear all history' > Clear history. Be sure to make a backup of your computer if you want to save any of your Safari files. – Brick May 22 '16 at 8:58
  • @Brick Yeah, but same result. I tried to install Safari Technology Preview and again I have the same result. I think it's little specific bug that difficult to repeat and catch. Thanks for your comments – Sanek Zhitnik May 22 '16 at 10:06
2

Try Safari/Preferences/Search and uncheck Include Safari Suggestions.

  • Thanks for your answer. I was waiting when bug comes again, and your solution is work. But i can't understand why this bug is shows itself randomly when this settings is checked. – Sanek Zhitnik May 28 '16 at 10:26
1

There was no updates installed for Safari or for OS X, but now tabs opens with focused address bar. I have cleared Safari's history and cookies, but it does not help at that time. I think it just elusive bug, because now I can't repeat it. I have only one decision - wait when OS X remove this bug itself.

  • Did you completely close Safari (⌘+Q) before the problem resolved itself? When you close your last tab, Safari stays open, just without a window. Quitting the app often resolves issues such as that one. – user11633 May 24 '16 at 17:07
  • 1
    I always use <kbd>⌘+Q</kbd> when want to close Safari. It's funny, but after yesterday's answer I have met three times this bug. Still searching what app or action leads to this bug. Thanks for your comment @Phong – Sanek Zhitnik May 24 '16 at 19:12
0

I think I might know what is going on. I had the same issue and I believe it was because I set the default home page in safari to Google. When I opened the browser (or a new tab) it switched the focus to the Google Homepage Search Box.

Under "Preferences / General / ..." changing the settings "New windows open with" and "New tabs open with" to something other than a website page fixed the issue for me and now any time I open a new browser window or tab the focus is set to the Safari Search bar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .