I am trying to replace the hard drive in an old MBP-15 mid 2010 with a new SSD. The old disk is encrypted. I did that on my own two MBPs successfully, but both disks were not encrypted. The Mac is running OS X v10.10.5.

I reboot the friends MBP with CMD+R into Recovery Mode and run Disk Utility -> Restore with the old drive set as "source" and the new SSD set as "backup"

It runs for a few minutes, but then it fails with

Could not restore - Device not configured

The SSD is brand new and connected to the Mac via USB.
Does anyone have an idea what is going on?

---------- Solution -----------

Thanks for the answers. The simple solution was to exchange the original HD with the still empty SSD and run restore in that combination. I believe it may have been some kind of USB problem, maybe related to the different read / write speeds (slow reading, encrypted disk vs super fast SSD write). Not sure, but it worked. Cheers!


3 Answers 3


The outcome you're seeing is probably a (security) feature, not a bug. I would think that Disk Utility would prompt for a password to enable access to the encrypted drive before allowing it to be read in order to perform the restore. Before attempting the restore use the Terminal command string "diskutil corestorage unlockVolume UUID -stdinpassphrase" followed by the password to unlock the drive then see if your restore runs to completion.


Could not restore - Device not configured

Means bad USB drive and need to replace it.

  1. If you drive encrypted you are not able to check this in another macbook because ist encrypted with your own and the UUID of the local system.

  2. If you able to open the drive at your current system, check the storage capacity of the drive it is very full you also get this error. You need to delete something to access your drive.

Hope this helps.


Had same issue, went and saw that the source disk was Case-sensitive, Journaled, and Encrypted, so I went to the destination disc and first erased it with same settings - Case-sensitive, Journaled, and Encrypted - then repeat the "Restore" operation as in this link https://discussions.apple.com/thread/5424527?tstart=0

and it worked. I had to repeat the process twice because the first time disc had to be unmounted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .