0

I cannot mount .dmg file for VMWare Fusion installer. I get the error: Protocol wrong type for socket .

I have Mac OSX 10.11.5 , which is newer than the officially supported versions of Mac for this installer. Hard to believe that is the problem though since this page says Fusion8 is designed for El Capitan.

I tried downloading both VMWare Fusion 8.1.0 and also 8.1.1 and neither will work. Test, I am also a administrator account on my machine. Maybe I am not a true administrator (since this is a work machine)?

I have no idea what that error means? Is there a way to manually extract a .dmg or some alternate download or method to unzip on command line ?

  • Did you check the MD5SUM or SHA1SUM of the downloaded VMware-Fusion-8.1.1-3771013.dmg file against its published values to see if the file is corrupted or not? Click on the Read More link under Product/Details to get the info. – user3439894 May 18 '16 at 22:11
1

If you can't even mount the .DMG file it is unlikely to have anything to do with VMWare or the software they put in the DMG file. Usually errors when mounting a DMG file occur due to a damaged download. Though it is possible the file they placed on their servers is corrupted at the source.

Try downloading with a different browser or even use WGET in the terminal and see what your results are.

  • I did try a different browser. I am waiting on a support call to get back to me... i think i am restricted by some kind of security policy that affects me from mounting the .dmg even though i am administrator. I'll update here later with the result but thanks for the suggestion, it helps. – djangofan May 18 '16 at 21:27
  • I do not believe you can use wget to download VMware Fusion. – user3439894 May 18 '16 at 22:12
  • If you can get a (web) URL for a file you can use WGET. If, however, they hide the download behind a bunch of javascript or a "download manager" the, yes it would be difficult to use WGET, which is used as an example of alternatives that could be tried. – Steve Chambers May 19 '16 at 0:31
  • Yes, confirmed by my IT department. The cause of the mounting error is a security policy being enforced on the Mac. – djangofan May 19 '16 at 1:00
0

Try rebooting your Mac.

Had exactly the same problem today including Vmware Fusion not starting.

Reboot fixed both on my side.

I'm assuming that there was an Apple update that required a reboot to finalise or something similar.

0

It's probably affecting all .DMGs

https://origin-discussions-us.apple.com/thread/7568956

  • Welcome to Ask Different! Please don't give link-only answers. We're looking for answers that provide explanations of why it answers the question. Links can change over time and then we'll lose the question-answer context. See How to Answer for info on what makes up a good answer. - From Review - – fsb May 26 '16 at 19:21
  • All other .dmg files work fine for me. For example, the Chrome Google Chat plugin .dmg installer works fine. – djangofan May 28 '16 at 18:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .