0

Recently every time I try to delete files, my OS asks me to type in a password. After I type in password, the files are deleted from the folder, but it doesn't free up space and the files don't show up in the trash, so I can't empty the trash. I've tried troubleshooting different ways from searching on Google and Apple forums:

  • I don't have Time Machine enabled.
  • I have OS X 10.7.5.
  • I've deleted over 100 GB of files, but I still only have 7 GB.
  • I've tried typing in Terminal:

    sudo tmutil disablelocal
    
  • I've tried typing in Terminal:

    resetpassword
    
  • I've tried typing in Terminal:

    sudo rm -r /.cleverfiles
    

Any other suggestions will be much appreciated.

  • 1
    We don't have enough information to help you. Try using something like DiskInventoryX to find out what is using the space and let's go from there. – John Keates May 16 '16 at 2:40
  • 1
    Have you tried repairing disk permissions? – Nikita May 16 '16 at 5:23
  • Is yours an Administrator, Standard, or Managed user account? – Munesawagi May 16 '16 at 11:38
  • Have you tried Trash It? – JMY1000 May 16 '16 at 19:16
  • Thanks everyone for all your advice, but I found out how to fix. It took me a few tries, but I followed these instructions from the below link. Just in case anyone else has this issue. cnet.com/news/… – Anthony May 20 '16 at 6:39
1

I have faced similar problem on one of the Macs in my office.

I couldn't solve it directly, so I chose to delete the account, by backing up of all the important folders/files into another partition. Alternatively, you may move it out of the home folder to another folder (e.g. /Users/Shared/) temporarily. I deleted the user account and created a new one, which will solve problems with permissions, clear hidden data in the account and/or configuration problems like you are currently experiencing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .