0

I am trying to run a python program, I installed python, 3.5 but it still says.

requires Python 3.4 or newer. 

When ever I try and start it, am I doing something wrong? I installed python via the package downloaded from the python website

  • How are you starting it? and what is your PATH? – Mark May 15 '16 at 19:07
  • python -m its a bunch of py files in a directory. – Alex May 15 '16 at 19:10
  • any your PATH is - what does type -p python show as the executable that python is? – Mark May 15 '16 at 19:11
  • /usr/bin/python – Alex May 15 '16 at 19:13
1

The issue is that your $PATH environment variable finds Apple's python 2.7 before the python.org one in /usr/local/bin

One way is to run the script as /usr/local/bin/python

Or run as python3

Another is to alter your path so /usr/local/bin is before /usr/bin . This has bee described in many questions

  • You can also do python3 **program** instead of just python **program** which will use the other version. – JMY1000 May 16 '16 at 20:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .