1

I need to use/integrate GCC 5.X (in my case 5.3, and it is already installed) on Xcode 6.2.

I've found a lot of outdated tutorials about GCC 4.X and Xcode 5 (or lower), but all of them are outdated and do not work anymore.

I've also found this tutorial, but I have not the 5.3.xcplugin file that the tuto recommend to copy.

I am still on Mac OS X Maverick, and I can install Xcode 7 if necessary.

Anybody would know how to do it?

  • As an aside I can only see wanting gcc for C++ issues if so Xcode is not that good an IDE for C++ and I would look for something else – user151019 May 15 '16 at 8:40
  • @Mark Any recommandation? – FiReTiTi May 15 '16 at 8:42
  • Unfortunately not they all seem to lack something :) Eclipse is OK its problem is not having the llvm debugger – user151019 May 15 '16 at 8:44
  • Ouch... I was using Eclipse for Java before, and I fed up about it. If it is ok for C++, I may use it, the absence of debugger is ok. – FiReTiTi May 15 '16 at 10:54
  • The debugger will be in Eclipse for gcc it is not there for llvm based code – user151019 May 15 '16 at 11:23

You must log in to answer this question.

Browse other questions tagged .