6

It has been two days of google-fu and I'm really out of ideas here. I live in Germany, just in case that's important.

Current situation

For a week now I haven't been able to connect my iPhone 5 (iOS 9.3.1) to the internet over my home Wifi. My router is a TP Link Archer VR200v (Firmware version 0.8.0 0.21 v002f.0 Build 151105 Rel.35502n, it's the latest one.), I think the international name of it is AC750. I use the VR200v as a router and modem.

Our DSL was down for a few minutes last weekend. While I'm not 100% sure those two things are related, ever since then, the iPhone hasn't been able to properly connect to my Wifi. The phone claims that it's connected but I can't open any websites and also can't access my router's configuration interface (192.168.1.1). I don't have any problems connecting to other Wifi networks and using their internet, I tried my university's Wifi and also used my other phone as a hotspot (Moto X Pure) which both work flawlessly.

I also don't have any problems connecting other WLAN devices to the network. Two laptops, TV, the Motorola, all work and have stable internet connections.

What I've tried

The router allows 2.4 and 5GHz frequencies. I tried both, with and without WPA2 passwords. Same results.

I wiped the iPhone and restored it from a backup, hoping to clear some sort of messed up configuration. It didn't make a difference. I tried connecting both the 2.4GHz and the 5GHz Wifi during the setup without restoring it first, same result.

I tried a different Firmware for the router, still no connection.

I tried manually setting the channel (tried several for 2.4 and 5GHz) and the channel width, which had been suggested by people with similar problems, that didn't help though.

Other people suggested disabling WMM on the router (i.e. http://www.ceus-now.com/wifi-connection-problem-iphone-to-tp-link-router/)

The problem is, I haven't found a way to disable WMM on my router. It claims that WMM is obligatory for the 802.11n und 802.11ac modes, which suggests that 802.11g allows disabling it. However I can only choose between 'Only 802.11n', '802.11gn mixed' and '802.11bgn mixed'.

_ _ _ _ _ _ _ _ _ _ __

So I'm really out of ideas here. I feel like some setting hasn't been deleted 100% and creates some sort of issue between the phone and the router. Has anyone experienced something like this before? I'm open for suggestions!

migrated from superuser.com May 14 '16 at 16:40

This question came from our site for computer enthusiasts and power users.

2

Solution

The last resort was resetting the Router and setting it up from scratch. It worked, WiFi is working on the iPhone again!

0

Resetting the iPhone was a good step, but restoring from backup may have restored faulty settings.

Another step to troubleshoot network connections is this more limited reset: Settings > General > Reset > Reset Network Settings.

Apple's guide to troubleshooting this issue is here: https://support.apple.com/en-us/HT204051

  • I forgot to add that to the list of things I tried, this was also one of the steps I found early on. I also thought that the backup might contain errors and be the cause here so I wiped the phone and instead of restoring it right away, I tried to connect to the Wifi from the iPhone setup process, you know right before you can choose between "set up as new" and "restore from backup", it wouldn't let me connect either though. – ulrich_k May 19 '16 at 10:48
0

I had the same problem with the iPhone 5s.

Check that you have not recently downloaded any new app which is not allowed in your country or banned like VPN secure or secure vpn.

Delete it and reinstall after getting WiFi signal.

0

What I did... I took the connection information from a wifi/internet functional smart phone... IP address Subnet Mask Router DNS

and manually entered it as a Static connection on the trouble causing iPhone... I disconnected the original smartphone so not to cause any conflicts and finalized on my iPhone... It seems to work now... we'll see how long it lasts!

0

Logged into router 192.168.1.1 Changed router to wpa/wpk to both. Iphone now works good.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .