1

My MBP crashed and had some permission issue on booting. I tried some repairs with the recovery session but now it has a kernel panic...

I have an external device I can boot from, and I made a copy of my hard drive using ddrescue.

When I tried to mount the .dmg created, an error appear (obviously) but I'm looking for a way to open it like in target mode (to see all files in it like a folder). I tried target mode using another MBP with FireWire connection but nothing appears, and the backup software shows me all the files without any name for both the hard drive and the .dmg file...

Does anyone have any ideas ?

  • 1
    The binary file created by dd or ddrescue is not an Apple Disk Image File (.dmg) and giving it that extension doesn't make it one, it's a RAW Disk Image. What was the ddrescue command line you used to create the copy of the HDD/SSD and was it of the whole disk or just one partition? – user3439894 May 13 '16 at 16:36
  • I used this command line : "sudo ddrescue -v /dev/disk0s2 /Backup/backup.dmg" (i found this here) – Edd Growl May 13 '16 at 17:17
  • Assuming the source disk was a standard OS X Startup Disk, then that command should have made a copy of the Macintosh HD and, in spite of the erroneous file extension, double-clicking it should, by default, automatically mount it using the /System/Library/CoreServices/DiskImageMounter.app. This is, of course, assuming the disk is not encrypted. So, what error are you getting when trying to mount the RAW Disk Image? – user3439894 May 13 '16 at 18:06
  • Well, as my source, the raw disk image can't be mount (this message appear : '"no mountable file systems"). I tried to mount it with terminal (hdiutil) and it return "succefully mounted" but nothing appear on finder. – Edd Growl May 13 '16 at 18:13
  • When you mounted it 'with terminal (hdiutil) and it return "successfully mounted"' did you look in /Volumes to see if it actually mounted? – user3439894 May 13 '16 at 18:25

You must log in to answer this question.

Browse other questions tagged .