0

I have a new iPhone SE running iOS 9.3.1, restored from a backup of my old iPhone 4S. Also I have changed carriers upon getting the new phone to Cricket from AT&T.

When I set up the new iPhone, it installed carrier updates from iTunes and the Phone app let me set up my visual voicemail with the passcode and custom greeting, and I tested it out and the visual voicemail worked.

Now, however, when I go to the Phone app and tap Greeting in the Voicemail tab, it brings up the page that would let me play and record a new greeting, but the only working button is Cancel. All the buttons appear as if they work but they don't respond.

I've tried resetting the Voicemail passcode in the Phone settings, I've tried resetting network settings, I've tried rebooting. The problem remains. What is the solution?

One other note, though I can't tell if this is coincidence or the cause, perhaps you can enlighten me: I wanted to completely wipe my old iPhone so it would be ready for another to set up as their own, but that phone's WiFi doesn't work right, and so in order to get internet access enough to unlock iCloud and do the erase, I took my Cricket sim out, and (with a nano to micro sim adapter that came with my Cricket SIM originally) put it in to the 4S so it could get some 4G internet and authorize the erase. After I put the Cricket sim back in the iPhone SE, I noticed it occasionally lose the LTE connection that I don't recall it doing previously in the last week that I had the new phone. Could be a fluke though. And I don't know if the Voicemail greeting problem was around before because I wasn't checking it and wasn't getting lots of voicemails exactly. Also I tried giving myself a test voicemail and it wouldn't let me play it back, though after some resetting or I don't know what the playback works again. Don't know if that's useful or irrelevant or rambling.

Edit: The bit about my iPhone losing LTE, I think I've narrowed down the problem. I think it's just because Cricket isn't yet using VoLTE and I wasn't testing many phone calls. As it stands though I cannot change the greeting except through calling voicemail directly. This is not a massive problem though I would like to know what could be going on or if I should contact Apple Support since this is a new phone.

Also I kept playing around with it and at one time I did get the Greeting controls to work. And then it stopped working again. Don't know what's up or why that would be caused. Is it possible what I did with the SIM would cause this?

  • Sounds to me like a cricket issue. The greeting exists on the server, not your phone. – Tyson May 13 '16 at 11:38
  • @Tyson Though I created it on my phone and a couple times I got the greeting tab to work and play it back. Just not usually. – kal-al May 13 '16 at 18:02
  • Did something which might have fixed it, cleared all deleted voicemail (and all voicemail) from the phone and quit it and re--opened and went to greeting tab and waited a few moments and it appears to work now somehow. – kal-al May 13 '16 at 22:09
  • You might have to call up Cricket to have it provisioned for your iPhone – Pinchus G. Aug 9 '16 at 0:37
  • @PinchusG. See my above comment. It started working again. It's actually been fine since then. – kal-al Aug 9 '16 at 2:00
1

Mine seemed to not let me play or record a new message (or switch it back to default) and all I had to do was wait ~2 minutes with the voicemail screen pulled up. It seems like it just needed time to load. After two minutes it began working as normal.

1

My Iphone 6 uses Verizon. I successfully changed VM greeting a couple of days ago then tried to change again the same day but none of the VM greeting buttons would work except cancel. Called Verizon and they had me reset all settings. Still didn't work. The told me to re-set network settings and still didn't work. The referred me to apple and I did a did a back up and restored using by back up. Still didn't work. They wanted me to try to restore as new without the backup which I was reluctant to do.

Just deleted VMs and Delted VMs, and (for now) I'm able to record and change my VM greetings. Thanks Kal-al

You must log in to answer this question.

protected by Community Aug 31 '16 at 18:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .