1

I recently bought a Thunderbolt to Gigabit Ethernet adapter so I could have faster Internet. I plugged the cable into my Internet modem, and the other end into my adapter. I plugged the adapter into one of my Thunderbolt ports on my Macbook Pro running OSX 10.11.3 El Capitan. The computer recognized it and connected to Ethernet. When I used speedtest.net, my WiFi had a lower ping and higher upload and download speeds than my Ethernet. I tried the cable to both Thunderbolt ports, all the ports on my modem, and my router, and even tried using a different Ethernet cable; it just wouldn't go faster on Ethernet.

I tried resetting my PRAM (Which has recently been changed to NVRAM, but is essentially the same thing), and deleting my Thunderbolt Ethernet setup in System Preferences. If you want to know;

Ethernet:

  • Ping=17 ms
  • Download=3.50 MB/s
  • upload=1.21 MB/s

Wi-Fi:

  • Ping=13 ms
  • Download=3.76 MB/s
  • Upload=2.19 MB/s

As you can see, my WiFi is not very good so I got the adapter to speed up my connection by using Ethernet. I just spent $30 so please if anyone can help I really need it.

  • 1
    What speed does your modem communicate with our ISP? How are getting internet? DSL, cable or other? – David Anderson May 11 '16 at 22:17
  • 1
    In my personal and professional experience, only the Apple-branded Ethernet <> Thunderbolt adaptor works. At my job, we tried several brands of adaptors a few years ago, some which were more expensive than Apple's, but most either did not work at all, or had miserable throughput | errors | network voodoo. If Apple no longer sells their own adaptor, whatever they have in the on-line store will work. – IconDaemon May 12 '16 at 0:10
  • I am using an apple adaptor, and it is working fine, it's just that the internet is not as fast as it should be while using it. – Brazen May 12 '16 at 0:45
  • megabit has a maximum speed of 12.5 MB/s, and actual speeds are usually lower than that. I remember when I was on megabit my speeds were similar to that of yours, wifi or ethernet. Also, do check if you're using a slower ethernet cable (cat5). – perhapsmaybeharry May 12 '16 at 1:14
  • Oops I mistyped that, It is a gigabit adapter. I am using a cat5 ethernet cable, but I assumed it wouldn't make much of a difference. Would this be the cause of my problem? I am getting my internet through cable, and I have 50Mbps coming from Time Warner Cable. – Brazen May 12 '16 at 2:49
1

I think there is something going on with El Capitan and a most recent update... My ethernet speeds (same network as an old Mac Mini) are 50x more (very seriously) than my iMac 5k. I get about 70Mb/s on the old Mac Mini and only about 1.5-2Mb/s on the iMac. I checked the network traffic, I checked the processing in the background ... nothing. That's changed recently (with nothing else changing) and I think it was due to an update. Frustrating though.

  • Damn it -- after all is said and done, I forgot the cardinal rule of networking ... reduce and simplify the network path until see the behaviour change... turns out, either my switch or cable seems to have gone bad. Taking it out of the equation, and everything gets back up to full speed. Stupid HW. Sadly, I always start with it must be a SW problem. Good luck with your issue (maybe reconfirm your cables/hardware as an interim check step) – Nick May 16 '16 at 4:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .