Last night, I shut down my computer. When I turned it back on, I just got the rEFIt logo (I have rEFIt installed). Usually, it takes a moment to populate the menu with a list of bootable devices, but this time it just hung there.

I had an Arch Linux Live DVD in the optical drive, too, and I can't make it eject or boot into Arch Linux. The optical drive whines when the macbook is powered on, but it doesn't keep spinning. This optical drive is old-ish (original to the 2007 macbook) and refused to burn CDs starting a month ago, so I've been expecting it to go any day.

Pressing down any of the boot keys (D, O, option, Command-Option-O-F, C) would just get me that blue screen you get when you're normally booting, but hung there. Target Mode and Single-User Mode don't work, either.

The hard drive is original to the machine, too, but I don't think the hard drive dying would interfere with the boot process. I would think I would be able to boot to the DVD if that were the case, too.

I asked this question on AskMetafilter last night. One of the things recommended was to reset the PRAM (boot with Command-Option-P-R) and the SMC (turn the computer off, take out the battery, and hold down the power button). That worked but didn't fix my problem. Now, I don't get the rEFIt menu, just that blue screen. Holding down any of the boot keys still doesn't get me anywhere.

What happened? How do I fix it?

3 Answers 3


If I remember correctly, holding down the button on the trackpad while booting will force-eject your optical drive. Have you tried that?


First boot holding the Option key and wait till you see a solid grey screen. This will let the system enter the boot chooser - the eject key (F12 on some keyboards) will get the optical disc out.

If you don't get to the boot manager, then you can struggle with the rEFIt software or burn an Apple irmware restoration CD - do check the downloads well - I don't know which version of CD is needed for a 2,1 model. Do make a comment on the model name of your mac (early 2008) or such from http://www.apple.com/support/manuals as the apple support articles use those names over the internal model numbers.

  • I've tried the option key; that doesn't get me anywhere. Neither will the eject key. It just stays on the blue screen. I can't do the firmware restoration CD because I have a DVD stuck in the optical drive.
    – Wayland
    Sep 1, 2011 at 4:13
  • 2
    If an Apple store is close by, the techs there are great at knowing the best way to get a drive out without damaging the eject mechanism. Have you tried booting with the track bad button held down? (alone or after resetting PRAM - wait for the third beep and switch from Command-Option-P-R to mouse within a second of the third chime)
    – bmike
    Sep 1, 2011 at 14:58
  • what happens if, after seeing a solid gray screen, you don't release the option key?
    – Thufir
    Jul 11, 2018 at 8:00

It's possible that your failing optical drive is flooding the logic board with errors. Take it to an Apple store or disconnect the optical drive yourself if you know what you're doing and try again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .