0

I have a 2006 15-inch MacBook Pro. I have upgraded the RAM to 3GB, and I have 9GB of free hard drive space.

I'm looking to upgrade the OS since it's currently running Snow Leopard (10.6.8), and not much software is compatible with it anymore.

I'm confused about how Apple states the system requirements for their operating systems because they list both technical specs such as RAM, processor, etc., and they also list compatible Mac models by year released, e.g. "MacBook Pro (Mid 2007 or newer)". OSXDaily also lists specific models by year but says that

A common thread is the Mac must have a 64-bit CPU, which is typically an Intel Core 2 Duo or newer processor. Beyond that, the requirements are pretty soft and forgiving.

Here is my output from the System Profiler:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro2,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.33 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 3 GB
Bus Speed: 667 MHz Boot ROM Version: MBP22.00A5.B07
SMC Version (system): 1.12f5
Serial Number (system): W86432AEW0L
Hardware UUID: 00000000-0000-1000-8000-0017F2C54B21
Sudden Motion Sensor: State: Enabled

So my computer meets the tech specs, but it is a year older than the oldest stated supported model. Practically speaking, what is the latest Mac OS version this computer will be able to run?

2

MacTracker says this version MacBookPro2,2 can have Mac OS X 10.7.5 as maximum OS.

As 10.7.5 needs at least 2GB memory and you have 3GB, I think you would have no problem upgrading to 10.7.5.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .