0

I currently have a Macbook Pro late 2011 15 inch which is running Mac OS X 10.7.5 which is a little outdated for my preference. When I run a software update there it says there is no software update available and when I open my Appstore it crashes so I can not download the update for El Capitan. Does this version of the Macbook not support later versions of OS X? How can I get around this issue and download El Capitan?

1

Here's the requirements for upgrading to El Capitan. Do you meet all the requirements, especially the free space?

enter image description here

0

http://www.apple.com/osx/how-to-upgrade/#hardware-requirements

El Capitan is usable for MacBoolPro Mid 2007 and newer, so yes your mac can run El Capitan

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .