8

I recently bought Sennheiser Momentum 2.0 bluetooth headphones and I use them mainly with my imac. After a bit of fiddling I figured out to force aptx via the bluetooth explorer and disable the handsfree profile as well, as countless people are recommending.

At this point I'm pretty happy except for one minor annoyance: I can't connect the headphones without OS X insisting on dropping the sound quality as if it were receiving a call and then deciding it is not a call after all and switching back to normal quality. I'm not sure if this is specific to OSX or the momentum 2.0, or both.

Symptoms: I turn the headphones on. Almost immediately it announces "connected", as it should. If any music is playing at this point it first plays at good quality but almost immediately it changes to very low quality. After a few seconds the head phone announces "call ended". From then on everything is fine.

I've been searching for a resolution to this but I haven't been able to find anything that even confirms this is a known issue. So, is there a way to skip the whole connected ... call ended ritual? I'm not actually interested in answering any calls with this thing.

  • can you share why disable handsfree profile and how to do it? – Tuan Anh Tran May 10 '18 at 1:59
  • I found the solution, go to Preferences > Sound > Input: select the internal microphone – Raheel Sadiq Aug 7 '18 at 7:42
9

It turned out the problem was Skype. I have this running all the time and when you turn on your bt headphones it tries out the microphone as if it was in a call before ending the call. The problem goes away if you don't have Skype running. Alternatively, you can connect your headphones with skype open and then switch to its sound settings end switch things back to internal speakers & microphone. It seems to persist these settings even when you disconnect/reconnect the headphones after that.

  • 1
    This did it for me as well. – Housemd Feb 11 '17 at 19:07
  • 1
    On OS X this currently seems to be an open issue caused by upgrading to Sierra (SIRI??) . I have to manually switch to the internal mic in sound preferences after connecting each time. – Will Ru Aug 15 '17 at 18:40

You must log in to answer this question.

protected by Community Mar 22 '17 at 12:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .