1

I have an iPhone 4s and an iPad 2. The 4s runs iOS 7, the iPad 2 runs iOS 9.3. On both devices, I have two Gmail accounts (one is straight gmail, one is a business domain), configured as Exchange accounts rather than Google accounts so new emails are pushed, not fetched.

Now, I just got an iPhone SE, restored from a backup of the 4s (and by the way on Cricket when the 4s was AT&T, but doubt that matters as my problem exists on WiFi too). Everything works on the new iPhone SE except the Gmail accounts no longer can get mail or connect to the server. They still work on the iPad. I know at first Gmail blocked my new phone thinking somebody else had gotten my password but I told it that that was me logging in and I can use both accounts as regular Google accounts or signing in directly with Safari. But I don't want email fetched, I want it pushed like o the iPad and the old phone.

I have tried deleting the accounts and re-adding them, and in the Accounts preferences area it seems to successfully connect and doesn't tell me that I have the wrong password unless I actually have the wrong password. But in Mail it just cannot connect to the server and I'm at a loss.

Does anybody have an idea of the cause and how to fix this?

2

I discovered the answer. It turns out Google disabled Exchange for new logins on iOS unless you have a paid business account. So for now my solution is to have the Gmail app installed so I get live notifications and use the default mail app to organize or write email.

1

I had the same problem after upgrading to iPhone 6sPlus and restoring my latest iCloud backup.

I also use a Google for Business email account.

I tried deleting and re-adding the account; didn't work.

I had to go into the admin console (admin.google.com) under Device Management and add the new phone as an approved device.

That fixed the problems immediately

  • Really? Everything I've read says this can't be done, unless you have a paid account. Do you have a paid account? My business domain and main Gmail domain are not paid. Secondly, how exactly do you get to the screen that lets you add a device I? – kal-al May 22 '16 at 3:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .