0

I have a Mid 2007 iMac, I've installed rEfind on the mac and the Linux Mint (Cinnamon 17.3) installer on an USB thumb drive .

rEfind sees the USB thumb drive, sees grub installed on the key, I boot from it and start to install Linux Mint, at a certain point I get this error: 'the 'grub-efi-amd64-signed' package failed to install into /target/'.

I manually set the partition table:
sda4 / k gb
sda5 swap 4096 mb

The iMac has a Core 2 Duo 2.0 Ghz, 3 GB RAM, and a NVDIA card.

I'll try again using the last UNebootin version, ad some different Linux distro (Xubuntu, Ubuntu, Lubuntu), but I'd like to know what issue could I have.

  • I have a few questions. How do you put NVDIA card in an iMac? Why have you not tried using the optical drive to install? Which partition (volume) did you install rEFInd into? Did you choose 32 or 64 bit Mint? Are you trying a BIOS or EFI install? What version of OS X? Do you also have Windows or some other OS installed? Does Mint have a live version and if so, did you try boot to that first? How large was sda4? – David Anderson May 8 '16 at 13:30
  • 1) the NVDIA is already into the iMac, it's a RadeonHD2400. 2) I didn't use the optical because I don't have a DVD to burn. 3) I just executed a script, from what I see it's in the Macintosh HD partition. 4) 64 bit Mint. 5) I guess it's an EFI, I didn't set anything about it. 6) 10.6.2 7) Yes, a 20 GB partition with Windows 7, it starts using eEFInd. 7) Yes, it has it and it works. 8) Don't remember exactly, 50-60 gb. – AR89 May 8 '16 at 17:39
  • I ask these questions because of my Mac. I have a 20-inch mid 2007 iMac with a 2.4 GHz processor and 4 GB of memory. I am running OS X 10.10, OS X 10.11, 64 Bit Windows 10 and FreeDos. I have rEFInd installed in a second EFI partition. I used to have 64 bit Ubuntu installed. Our machines are almost the same. I can not imagine why you are still running OS X 10.6. You do know that upgrading OS X and Windows are both free. – David Anderson May 8 '16 at 19:25
  • Windows was installed just for games, OS X can't be upgraded because newer drivers have a bug with the graphic card: it freezes the Mac, I had to restart each time it happened (very often) – AR89 May 8 '16 at 19:58
  • This comment is was entered from 64 bit Mint booted in live EFI mode from a RW DVD. I do not have time right now to try an install. I could later this evening if you think this might help you. From what is see so far, the live version of Mint executes faster than Ubuntu. – David Anderson May 8 '16 at 20:09
1

Took me weeks, but finally solved it for my case.

My install would go well, but the installation of grub would fail with the same message because of corrupted data in the EFI partition.

Fastest fix was to run a windows chkdsk to fix the partition, then the next install went fine.

  • windows chkdsk? isn't the question regarding a Mac? – xdavidliu Mar 13 '18 at 15:56
1

I had the same issue on my 2015 macbook air with High Sierra installed, trying to install via USB disk made with UNetbootin. Initially tried disabling csrutils in Mac OS recovery mode, and also made sure to check "Download updates while installing" during the Ubuntu installation (I had to click "back" after installing the wifi drivers on that screen in order to do this, since the two checkboxes are on the same screen in the ubuntu installation wizard). I also tried installing with and without REfind.

With the variations above, I tried four times and every time I got the dreaded "grub failed to install to target" message, and the installation crashed.

However, on the fifth try, I did one thing different: I made a swap partition during the partitioning part of the ubuntu installation wizard (previously, I had chosen to continue without a swap partition, and just ignored the warning message I got. As for the rest, I had csrutils back on because I didn't think that caused any troubles, but still made sure to check "download updates while installing". This time it worked, and there was no grub failure message. For the rest of the installation, I followed the instructions here for installing without REfind.

By the way, if you install without REfind according to the instructions linked, ubuntu will be set to the default boot OS. To boot into Mac OS, you would need to hold option after powering on/restarting, then select it. To change the order, you cannot use the Startup Disk system preferences, since you won't see Ubuntu as an item. However, there's a very easy trick to set the default: hold option after boot, then when you get to the screen with the Mac Boot where you can select either Mac HD or EFI Boot (ubuntu), hold CTRL and the up arrow below Mac HD will turn into a circular arrow. Click on that, and Mac will be set as the default!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .