1

My Finder on MBP has been giving me problems for a quite a few days and has become completely unusable. Once I start it, it opens fine but then I can't do anything. And it shows a scrambled view with images from background sometime (see below screenshot). Cliking on links on the side bar like Documents, Airdrop, etc has no effect. I have tried doing relaunch several times as well as restart. But no resolution.

Has anyone faced such an issue before? I am afraid this might be a virus but I am not sure.

enter image description here

6
  • Do other applications work ok? – nohillside May 7 '16 at 7:11
  • Check your system logs - it could be a malfunctioning graphics card, or graphics driver problem. – jksoegaard May 7 '16 at 7:27
  • @patrix the other apps work fine. In some rare instance, the finder too works fine for some mins. – RajeshShah May 7 '16 at 8:53
  • @jksoegaard Can you please provide the steps for that? – RajeshShah May 7 '16 at 8:53
  • I am leaning towards it being a graphics issue as well. However, you should run the Apple Hardware Test by holding the "D" key while booting from a powered off state. Be sure to leave your MBP plugged in. support.apple.com/en-us/HT201257 Be sure to run the extended test and provide the result in your question when finished. – Allan May 7 '16 at 16:04
1

This looks like a graphics card issue. I would recommend reseting your computer's PRAM. To do this follow the following steps.

  1. Power off your computer

  2. Locate the command ⌘, P, and R keys.

  3. Hold the power button until you hear the startup sound.

  4. Immediately after you hear the startup sound, hold down the three keys from step 2 until your computer boots a second time.

This should resolve your problem. If your problem still persists you can download a 3rd party software such as https://gfx.io, which will force your mac to use it's alternate graphics card. Just install it and on your toolbar at the top of your screen click the "i" and change the setting from "Dynamic Switching" to "Discrete Only." This will force your mac to use the NVIDIA card, and resolve your issue. I would recommend to try and reset your PRAM (Which has been changed to NVRAM, but is essentially the same thing), and only use my second solution if your graphics card rendering is still corrupted.

EDIT - To stop finder from being unresponsive you can follow these steps:

  1. power off your computer

  2. hold shift immediately after you hear the startup sound. This will boot your computer into safe mode.

  3. Open finder. The buttons should now work. Navigate through a few different directories.

  4. Click the apple in the top left. Click restart and you should be able to use finder again.

The reason this may fix your problem is because when you boot into safe mode, it cleans and resets some things, which can fix your unresponsive finder issues. If that doesn't work my last fix that I can think of without more information would be to open up the terminal application and type in this: sudo find / -name ".DS_Store" -depth -exec rm {} \; make sure that you typed the capitalization right and it looks exactly like that, and press enter. Type in your password. the letters won't show up when you type but don't worry the computer knows what you are typing. When you are done press enter. Reboot and it should be working again. If you want an explanation here it is. In every directory your Mac automatically creates a hidden file called .DS_Store. This file has information on it and after an update, or if something else happens, it can become corrupt or invalid. Executing the above command will remove these files so your Mac will create updated ones that work. While some of these solutions edit invisible files on your computer, it will not affect your computer in any way that you can see other than (Hopefully) fixing your problem.

5
  • Thanks. Will try that out. Any reason why it happens only with Finder? – RajeshShah May 7 '16 at 16:50
  • My best guess would be that there was an update and the old Finder configuration is being used in the new update. Reseting your NVRAM should reset the data on your graphics card so it can automatically update the Finder data the newest version. – Brazen May 7 '16 at 17:06
  • I did the PRAM reset but it hasn't worked. – RajeshShah May 9 '16 at 5:42
  • Also take a look at the edit to my original answer, that should stop it from being unresponsive. – Brazen May 9 '16 at 6:56
  • Thanks. The solution in edit seems to have solved the issue. – RajeshShah May 15 '16 at 6:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .