I recently reinstalled OS X, which with my MacBook Pro (2012 Model) meant that it grabbed Lion from internet recovery. It successfully installed, and I installed some updates, but when it comes to upgrading to Mavericks or El Capitan, the App Store crashes, the download shows up in the Launchpad screen, but never downloads or even tries to download, and I'm left wondering why. Every google search reveals something similar, but nothing exact.

I've tried signing out and signing in again, I've tried enabling debug and clearing cookies and resetting the app store, I've even copied and deleted the com.appstore.plist and com.apple.appstore.plist.

I'm at my wits end here. If not for the fact that I use OS X, I would wipe it and install Linux in it's stead. Any help would be appreciated.


Per the request of J.C., I've run the download with the console open to get some diagnostic information. Here are the two lines that show up in the console when I start the app store and download El Capitan.

5/6/16 10:24:02.302 AM com.apple.SecurityServer: Failed to authorize right 'system.install.apple-software' by client '/System/Library/PrivateFrameworks/PackageKit.framework/Versions/A/Resources/installd' [266] for authorization created by '/Applications/App Store.app' [259]

5/6/16 10:24:02.324 AM com.apple.SecurityServer: Failed to authorize right 'system.install.software' by client '/System/Library/PrivateFrameworks/PackageKit.framework/Versions/A/Resources/installd' [266] for authorization created by '/Applications/App Store.app' [259]
  • Could you look into the console (/Applications/Utilities/console.app) and post the entries there? You may have to retry starting the 'App Store' and try downloading El Capitan again to get some relevant Log-Entries
    – J.C.
    May 6 '16 at 7:06
  • Try if this happens with other apps from the MacAppStore too (choose some of the free stuff, e.g. 'SimpleMinds Free'). Also: Are you currently downloading via some managed network, e.g., at a company office? May 6 '16 at 16:09
  • Can you take a look through Launchpad for paused downloads/installations. Goto Applications->Launchpad and look carefully for greyed out app icons that say paused.
    – Brian Duke
    May 6 '16 at 16:40
  • @DictionaricsAnonymous: I'm actually downloading from my home network. user3623501: I've checked and there are no paused downloads/installations in Launchpad. May 7 '16 at 0:52
  • Also, I downloaded a free game, and it downloaded without issue. May 7 '16 at 1:57

Alright, so it turns out that a stick of RAM had gone bad, but OS X didn't see that it had gone bad. I ended up testing both sticks to make sure that one of them worked, and now I've successfully installed Lion, and upgraded it to El Capitan. Thanks for the suggestions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .