2

Previous questions/answers dealt with the simple case of a single partition on the USB disk that was just overwritten with dd. Also it looks like the disk utility gui doesn't allow creation of multiple partitions on a usb drive now. Anyway:

I've created 3 partitions on my stick, with the command: diskutil partitionDisk disk4 3 APM hfsx d1 1.35G ExFat d2 1.25G ExFat d3 13.0G.

This actually left me with 5 partitions:

Finished partitioning on disk4
/dev/disk4 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        *16.0 GB    disk4
   1:        Apple_partition_map                         32.3 KB    disk4s1
   2:                 Apple_Boot Boot OS X               134.2 MB   disk4s2
   3:                 Apple_HFSX d1                      1.2 GB     disk4s3
   4:               Windows_NTFS d2                      1.3 GB     disk4s4
   5:               Windows_NTFS d3                      13.4 GB    disk4s5

I've got a bootable linux ISO. Which device should I dd it to? The original target was supposed to be the 1.2Gb partition that is marked disk4s3. I don't know what the other stuff before it is. Should I just dd to /dev/disk4s1 and let it overwrite stuff after it?

  • Is the ISO image one that anyone can download? If yes, I'd suggest you edit your question adding the exact name and source of the ISO image so we can investigate using the actual image. Otherwise it's senseless to waste any time trying to figure this out. – user3439894 May 7 '16 at 0:51
2

You can use Unetbootin to copy the Linux ISO to 1.2GB partition(disk4s3).

If I were you though I would first rewrite the partition type as GPT instead of APM by running:

diskutil partitionDisk disk4 GPT fat32 Linux 10% ExFat d2 10% ExFat d3 80%

Then select the Linux partition on disk4 in UNetbootin to be the destination for the ISO copy.

  • This got me farther than before. unetbootin finished but said "this disk won't be bootable on a mac, use on windows" or some such. I tried booting to it anyway - the EFI usb disk showed up in the disk manager, but the machine just hung when I tried booting it. In Disk Utility, info on the partition shows "Bootable: No". Should I try to "fix" the partition w/ rEFInd next? – adapt-dev May 6 '16 at 1:54
  • 1
    I think rEFInd should be able to boot it. I think the Mac boot loader has issues booting non-apple EFI boot images – Brian Duke May 6 '16 at 2:23
  • What type of Linux are you trying to install? I ask because I was unaware any Linux iso could be copied to a USB flash drive with multiple partitions. Also, rEFInd is usually not required to install Linux on a Mac. Of course, there is nothing wrong with using rEFInd. – David Anderson May 6 '16 at 2:42
  • @DavidAnderson a small debian instance that fits in 1GB. I was hoping to partition the usb stick because it is 16Gb and seems a waste. So it is not possible to have partitions on a bootable usb stick? – adapt-dev May 6 '16 at 16:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .