0

I have a very strange problem with my iPad Air 2.

The problem is that certain apps crash immediately on launch. I tap the icon, the start screen shows and then the app crashes. This does not apply to all apps just a few. I have not been able to find a pattern. Even Apple’s own “Remote” app is one of the apps.

If I launch the exact same apps on my iPhone, iPad Air or my iPad Pro they work just fine. I am logged into the same Apple/iCloud account on all devices.

I have tried the following:

  • Launching the apps in airplane mode, with/without wifi and with/without bluetooth active.
  • Deleting and re-installing the apps in question.
  • Deleting, restarting the iPad and then re-installing the apps.
  • Reset all the settings and apps on the device restoring from a backup with iTunes.
  • Reset all the settings and apps on the device setting it up as a new device. Afterwards I downloaded the apps to the device and attempted to launch them.
  • Downloaded the current iOS version (9.3.1) from the developer’s page (IPSW file) and then alt-clicked restore to select the IPSW and really re-install iOS on the device. Installed it as a new device and then downloaded the apps in question.

All attempts have been fruitless and futile. Otherwise I could mention, that the iPad is a cellular model and has never been jailbroken.

Does anyone have any ideas what I could still do? Or is my only hope visiting an Apple Store nearby?

Thanks kindly for any feedback.

PS: I almost forgot the apps in question have never opened correctly on this specific iPad Air 2. My friend's iPad Air 2 can use the apps without any problems. So it does not seem to be a device-type specific bug.

  • You've already done everything I would've suggested. Have you looked thru any of the logs using Xcode? You should be able to see the crash messages from there. – fsb May 5 '16 at 14:18
  • yes - but these are also not very informative. There are EXC_BAD_ACCESS of the SIGSEGV (KERN_INVALID_ADDRESS), SIGBUS (KERN_PROTECTION_FAILURE) and SIGILL variety. And all the listed entries are all from core or standard iOS libraries. – Joseph May 5 '16 at 14:28
  • Maybe you have a bad memory chip or something like that? Based on what you've already tried, can you return the iPhone and exchange it for another one? I know this is probably the last resort, and hopefully others here can come up with something, but it might be your only option. – fsb May 5 '16 at 14:52

You must log in to answer this question.

Browse other questions tagged .