0

I have a strange issue with my early 2015 13" Macbook pro. The keyboard and touchpad no longer works during boot or in OS X. I can't, for example, use the internal keyboard to boot from USB, but have to hold down option on an external USB keyboard to select startup disk. Even the caps lock key light doesn't turn on when pressed. However, I can use the internal keyboard to do an SMC reset and both touchpad and keyboard works fine when booting Linux from a USB stick. External mouse and keyboard also work fine.

The computer was working fine in the evening. Before going to bed I placed it in my bag, and in the morning when I resumed from sleep neither touchpad or keyboard was working. I think I restarted the computer due to an update earlier in the day before it stopped working.

What I've tried:

  • SMC reset
  • NVRAM reset
  • Clean reinstall
  • Reseat the keyboard connector on the logic board.

None of them changed anything. Any suggestions would be very welcome!

  • I did a bit of research but couldn't find a solution...I would bring it on down to the Apple Store. – Munesawagi May 4 '16 at 13:36
  • How does it not work during boot, but you can do an SMC/NVRAM reset? That would mean it works during boot. If you can do those things, run Apple Diagnostics by holding the D key while booting from a powered off state (make sure your AC adapter is plugged in) – Allan May 4 '16 at 13:40
  • @Allan I added some info to clarify. But basically I can't use the internal keyboard to select startup disk during boot. Using an external USB keyboard works. – Albin May 4 '16 at 14:29
  • @Angelplayer I'll do that on Monday if I haven't solved it by then. It's not under warranty so I'm a bit worried about my wallet though. – Albin May 4 '16 at 14:31
  • When selecting the startup disk, are you holding down Option or another key? Have you tried Apple Diagnostics ? – Allan May 4 '16 at 14:39
0

EDIT: It turned out to be water damage that caused the issue. Fiddling with the case probably shifted some leads inside the computer that had shortened/lost contact.

So I think I've finally found the problem; the bottom of the case wasn't on properly.

The keyboard/touchpad would sometimes work, but after putting it in my bag and taking it out again it would usually not work anymore. However, after turning it off by holding the power button and carefully squeezing the case along the edges it would work when I powered it on again. The Macbook provides the ground connection for the keyboard via the bottom of the case, so my guess was that there was a problem with that connection.

So I took off the bottom of the case, cleaned it, and put it on again, careful to screw it in exactly straight, and now it seems to be fine.

I still don't know why it would work better in Linux. My only conjecture is that Linux can somehow reinitialize the hardware after it has lost power briefly.

  • Could you give a source on keyboard grounding that you mentioned? what does that? – temo Mar 22 '18 at 0:53
  • @Albin you are right! i have exactly the same problem too. It works after removing & putting back the bottom case in 3 attempts. Thank you for sharing. – Chris O Aug 22 '18 at 23:24

You must log in to answer this question.

protected by Community Aug 23 '18 at 0:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .