3

When entering my password into App Store I get:

There was an error connecting to the Apple ID server

I checked the password and it's fine. I changed the password just in case, it still does not work, but now my whole Mac is disconnected from my iCloud account.

When I open Console, I get:

2016-05-01 9:17:06.292 PM com.apple.xpc.launchd[1]: (com.apple.auditd[1047]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.auditd

2016-05-01 9:17:06.300 PM myusername[1052]: audit warning: soft /var/audit

2016-05-01 9:17:06.300 PM myusername[1053]: audit warning: closefile /var/audit/20160502011137.20160502011706

2016-05-01 9:17:06.300 PM myusername[1051]: audit warning: allsoft

2016-05-01 9:17:06.499 PM akd[300]: NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9807)

2016-05-01 9:17:06.700 PM akd[300]: NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9807)

2016-05-01 9:17:06.898 PM akd[300]: NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9807)

It seems like people get the last error when they're using an iOS 9 app that doesn't support TLS 1.2.

I'm using OS X El Capitan 10.11.4.

Edit: same issue using Safe Boot.

5

I've had the same problem with App Store and Icloud for some time. For me the root cause for was a security hardening tip to enforce OSCP and CRL verification.

To see if you have the same problem start "Keychain Access" and open "Preferences". Select "Certificates" and verify that you have "Best attempt" for CRL and OCSP. After changing these values back to "Best attempt" I could login to Itunes. I had to restart to be able to login to App Store.

  • Thank you so much! I just got Apple Support on the phone for 1h 40min to no avail. You rock :) – pyb May 8 '16 at 1:17
  • Worth noting that this is could also be due to corporate firewalls performing man-in-the-middle attacks against SSL and iTunes using certificate pinning. Taking a look at TLSv1 client hellos and server hellos, it looks like a statement to not decrypt URLs matching gsa.apple.com should work. – mbrownnyc Oct 26 '16 at 21:03
  • I don't see "Certificates" entry in preferences dialog of most recent Keychain Access app. – Babken Vardanyan Mar 13 '18 at 12:52
-1

This worked for me to

Key Chain > Preferences > Certificates > Best Attempt

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 23 '16 at 12:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .