1

Today i format my "OS X El capitan" partition for installing "Yosemite". But due an error in bootable yosemite usb it didn't install on this partition. After some hours when i turned on iMac and hold down "option" key for boot into usb but just blank screen and mouse show. And every time when i turend on iMac it only show flashing folder with question mark. I've tried to resolve it by reseting "NVRAM". But after restarting problem still same. Also I've tried many "Startup key combinations for Mac" but didn't work any combination on startup. Also i have important data in my other one partition. Please can anyone tell me what i do for resolving that issue Without loosing my data?

  • Yea you are kinda stuck. :| You can attempt to fix this if you have another PC or Mac. – E2Busy Apr 30 '16 at 18:18
  • This is my iMac [everymac.com/systems/apple/imac/specs/… Yes I've tried "Cmd-R" this combination but didn't work for me? I have also macbook pro and PC, can you please tell me how i can fix that issue? – ZAFAR007 May 1 '16 at 9:00
1

This error appears when the startup disk's operating system is corrupt. The safest way to recover the drive's data is to pull it out of the machine and connect it to a different machine. However this is difficult and not likely an option for you. I would try getting someone you know to create a bootable flash drive of an operating system (which system doesn't really matter). You can use this drive to either 1) access all of your files or 2) reinstall a working OS.

1

Your iMac cannot find a Bootable Volume

I am assuming you have something similar to the image below. This means that your iMac can't find anything to boot off of. It can be for any number of reasons - a corrupt drive, a new drive, a missing drive, etc. But basically, your iMac searched and found nothing to boot from.

enter image description here

Recovering Your Data

Stop everything you are doing on that iMac! The more you do to your drive at this point lessens the chances for data recovery. Your very first priority is to try and recover the data you had on there.

For that you will need a good recovery program. I have personally used DiskDrill with great success. You can use it in Free Mode to scan your drive and see what is salvageable before you buy.

If you go this route, you are going to need an external USB drive (I personally swear by Western Digital) If you don't have one, now is the time to purchase it because you are going to want to use it now for the recovery and later for your Time Machine backups.

Once you have recovered what you can, it's time to move on to the next step...

Recovery Mode

Since you said that your drive formatted and/or partitioned, you more than likely wiped your recovery partition. All is not lost. Depending on the age of your Mac, you have a couple of options

  • You can do an Internet Recovery. Hold down Command R while powering on your iMac. Pretty much all Macs manufactured after mid 2011 support Internet Recovery. The Macs that can be upgraded to support Internet Recovery are listed on Apple's website: Computers that can be upgraded to use OS X Internet Recovery.

  • Have someone download the El Capitan Installer and create bootable USB.

  • If you have access to an Apple store, you can take your machine in and they will allow you to download El Capitan using their network for free.

  • You may be able to find bootable media on eBay. If you go this route make sure you buy from a seller with a good reputation and is US based.

  • Never, never, never get your bootable image via a Torrent site.

Set up Time Machine

Once you have everything recovered (what you can recover), I strongly advise you to set up Time Machine for backup and recovery. It's not difficult - you just use the USB drive I mentioned earlier, set TM to back back up to it and, if applicable, tell TM what you don't want to back up.

0

Can't you boot from recovery partition and download again? http://osxdaily.com/2012/02/03/how-to-boot-into-os-x-lions-recovery-hd-partition/

  • I've tried that method you mention in above link but not work for me still same issue when i hold down the key it only show blank screen with cursor? – ZAFAR007 May 1 '16 at 8:49
  • So I think you should try the steps described by @Allan. For me the first attempt should be the bootable USB (easyest) if you can. – FredericP May 1 '16 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .