0

I'm a user of an iPhone 4 with iOS 7.1.2.

When I want download an app, it tells me it need to update to iOS 8.4, but it's not supported for the iPhone 4!

Is this only a requirement for specific apps or it is a bug?

  • You ask if it's only about a specific app- which app? The App Store page will tell you the minimum system requirement for the app. – Hawken Rives Apr 30 '16 at 14:39
  • A newer iPhone will allow you to make it to iOS 8.4 allowing you to get any app that requires 8.4 or above. – E2Busy Apr 30 '16 at 18:23
1

screenshot of iOS app

If you open the App Store page for an app and scroll to the bottom, there's a section titled "Compatibility" that will tell you what the minimum version of iOS is that the app requires.

(This is not a screenshot of the OP's problem app, but rather The Infinite Arcade, which was the first app I saw.)

0

Apps which require features not available in older iOS versions can not be downloaded on these older versions. The minimum OS requirement is listed in the description of the app in the store.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .