0

So I've got a MacBook Pro which I use for work (and thus every file is precious information) and my BootCamp partition was getting a bit small, so I resized it with GParted, but not before resizing the OS X partition using diskutil.

However, after modifying the partitions, when I hold the option key at boot, I exclusively see the "Windows" partition, no Macintosh HD or Recovery HD.

I can see both of these drives from Windows, and all files are intact.

Is there anything I can do to repair this without

  • Requiring a backup drive (My backups are done to a NAS and thus cannot be booted)
  • Damaging any data on the device
  • Going to the Apple Store (Nearest one is a good few hours away)

Can I use the Internet Recovery system to get into a recovery environment?

Edit: I should mention I have a 64GB flash drive that I can use for anything, and the backups are exclusively of my "Documents/IdeaProjects" folder since that's the "important" work-related stuff. All of Windows and my personal files are not backed up (since the NAS is a work-owned system)

Further edit: I can no longer boot to Windows. I should mention that the value of th data on this drive is such that I am fully willing to pay a professional recovery company anything to recover it. How does that process work if I need to do it?

-1

Alright, I fixed it. I installed a Live image to my flash drive and copied the TestDisk software to it. My live image was Windows 10 To Go, but I believe any OS could handle it.

Then, I ran a scan using TestDisk, and re-enabled the "deleted" partitions. After doing this, I wrote the new GPT to disk, and rebooted. Held the option key, and the partitions showed back up.

I essentially followed this guide, but since my partitions weren't actually in the partition table, it showed them as 'deleted' - setting them back to 'primary' and writing it fixed it.

Moral of the story - Don't mess with any partitions on a Mac from anything else than software in OS X or you may trash your partition table.

  • I downvoted this answer. IMO it's not the recommended way to solve the problem. Especially in the extended scan mode TestDisk shows a lot of erroneous results. The proper way probably is: use fdisk results to restore the OS X partitions with gpt. I can't say this for sure because the question is missing important information: the gpt & mbr table. – klanomath Apr 30 '16 at 3:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .