47

I have noticed a lot of Adobe processes are running in the background at start up on an OS X 10.11.4 (15E65) machine with Adobe Creative Cloud (CC) installed.

To get rid of this, I removed everything with "*adobe*" in the filename from the directories used by launchd, which are: ~/Library/LaunchAgents, /Library/LaunchAgents, /Library/LaunchDaemons, /System/Library/LaunchAgents, /System/Library/LaunchDaemons.

It's not a bad idea to browse these directories manually just to get aware of what is - or could be configured to be - launched automatically on your machine.

However, using this approach I got rid of all Adobe processes but one with the process name Core Sync Helper. The process' UID is me, not root.

Using the OS X activity monitor to get more information about this process it tells us that its parent process is launchd. The process' path is:

"/Applications/Utilities/Adobe Creative Cloud/CoreSync/Core Sync.app/Contents/PlugIns/ACCFinderSync.appex/Contents/MacOS/ACCFinderSync"

How does Adobe get this process to be launched automatically?

And how to stop it from being launched automatically?

Update:

According to YoshiBotX's answer, I used launchctl list as well as the App launchControl to find the service that launches the Core Sync Helper. To do so, I search for a service with adobe, accf or core*sync in its name. Unfortunately, there is no such service with an obvious name. All services on the system are by com.apple.... or from a third-party App that hasn't any relation to Adobe.

Also, launchctl list lists the PID of each Label. But the PID of the running ACCFinderSync process is not listed there at all. However, as mentioned before, its parent process is still launchd so I wonder how this can be.

Update 2:

Using launchctl I was able to gather more information about the service using its PID (omitted lines marked as ...):

macy:~ jens$ sudo launchctl procinfo 352
...
com.adobe.accmac.ACCFinderSync = {
...
com.adobe.accmac.ACCFinderSync.apple-extension-service
...
com.adobe.accmac.explinder
...
ACCFinderSync
...

But these aren't service which I can remove using launchctl.

Update 3:

Based on chiggsy's answer I was able to find more traces of the service (omitted lines marked as ...):

$ sudo launchctl print gui
    com.apple.xpc.launchd.user.domain.501.100008.Aqua = {
    ...
        unmanaged processes = {
    ...
            com.apple.xpc.launchd.unmanaged.ACCFinderSync.352 = {
                active count = 5
                dynamic endpoints = {
                    "ACCFinderInnerExtensionHost2" = {
                        port = 0x59a8f
                        active = 1
                        managed = 0
                        reset = 0
                        hide = 0
    ...
        externally-hosted endpoints = {
             0x59a8f    U   A   ACCFinderInnerExtensionHost2
    ...

$ sudo launchctl print user
    com.apple.xpc.launchd.domain.user.501 = {
    ...
        endpoints = {
    ...
             0x59a8f    U   A   ACCFinderInnerExtensionHost2
    ...

$ sudo launchctl print system
    com.apple.xpc.launchd.domain.system = {
    ...
        subdomains = {
    ...
            com.apple.xpc.launchd.domain.pid.ACCFinderSync.352
    ...

But that still did not help me to disable it.

Update 4:

kirb nailed it!

83
+50

This is a Finder Sync extension.

To stop the process:

  1. Disable the check box in system preferences
  2. Log out and back in (or restart if you have more than one user logged in to your Mac)

In OS X, the Finder Sync extension point lets you cleanly and safely modify the Finder’s user interface to express file synchronization status and control. Unlike most extension points, Finder Sync does not add features to a host app. Instead, it lets you modify the behavior of the Finder itself.

Extensions are parts of an app that are able to integrate with certain core components of the OS. Finder Sync extensions in particular enable tighter integration with Finder by way of sync status badges, and allowing buttons to be added to the toolbar, sidebar, and right click menus.

OS X keeps a database of all known apps on your computer, and this also includes any extensions (.appex bundles). When Finder launches, it queries this database for Finder Sync extensions and launches them. For security reasons, each extension lives in its own process.

Fortunately, you can disable this easily from the System PreferencesExtensions pane (grey puzzle piece icon) – just untick Finder under the app name in question.

Extensions preferences

  • 4
    so easy? facepalm – Jens Wirth May 8 '16 at 17:11
  • 1
    I was racking my brain looking for this as well. Hands down though LaunchControl (a GUI front-end to launctl) is one of the best interfaces to manage these things. However, it doesn't handle these types of extensions. Thanks again! – Freddie Jun 16 '17 at 15:47
  • @Freddie - I love you! – SpaceDog Jan 28 '18 at 11:15
  • Is there a command line way to disable Finder extensions (or at least the specific Finder Sync extension)? – studgeek Apr 6 at 17:09
3

Another guess would be to check in /Library/StartupItems.

But launchctl does not require your service.plist to be located in one of those directories.
In fact, you do not even need to have a file (as seen in the launchctl submit).
So as long as you register it with launchctl load|submit, it will be kept running/starting.

I think your best way is to disable the tool with launchctl directly or by using an Application like LaunchControl.

  • Good hint! Unluckily, the process doesn't seem to have any corresponding launchctl service. I updated my question with details about this. Did I got you right? – Jens Wirth May 6 '16 at 5:58
  • @JensWirth , good so far. have you tried looking at 'sudo launchctl list' ? I get a few more services that way? – rwenz3l May 6 '16 at 13:55
3

launchctl has changed for the better in 10.11.4

Type the command without arguments to get the help. You'll see new domains to search and new commands.

launchctl print system     #prints the system domain (root)

launchctl print system/com.system.service     #prints details about a service in roots domain.

For your processes: if it's not in the system domain it's probably in your user:

launchctl print user/(your uid)/
launchctl print user/(your uid)/com.user.agent

However, since you'll be logged into the gui:

launchctl print gui/(your uid)/
launchctl print gui/(your uid)/org.adobe.NSAmonitor # or whatever they call what you are looking for

Gui domain for things that have a UI/Agents

User domain for daemons for you.

System domain for system daemons.

There are a couple more but I find user and gui are pretty good.

The trick with later versions of OSX is to check the man page and then run the tool help. If it's running, you can find it with launchctl.

man launchctl
launchctl -h

Good luck.

1

The problem is that over the last years Apple has introduced other ways to auto-start items than having plists in specific folders like it works with launch agents and daemons. xpc services, smloginitems are not located in these places but are registered in the launchctl database (can be seen by launchctl list) but this specific adobe plugin obviously gets loaded at start but is NOT listed by launchctl at all. you can see some info by using launchchtl print user/501 but not by launchctl list. so what exactly is ACCFinderSync and why does it not show up? the hole launch system is kind of splintered up atm and it is very complicated to observe all forms of startup items. the big question here is: what are application extensions (appex) and how can they get detected (and disabled) at command line level if not by launchctl.

You must log in to answer this question.

protected by bmike Apr 23 at 2:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .