11

I want to transfer files in Recovery Mode https://support.apple.com/en-us/HT201314. I opened Terminal in Recovery Mode and tried to copy files to external hard drive. I use this code

// I used cd .. to get to the topmost folder
cd Volumes // takes me to volumes
ls
cd OS\ X\ Base\ System
ls

The problem is that this creates a loop. Upon cd-ing to OS\ X\ Base\ System it takes me back to the start, namely the / folder that contains Volumes. I want to copy the whole Document directory and Desktop directory. What I am doing wrong?

EDIT>

When I first enter the Terminal, I am in private/var/root/Library, the system created a var folder when figuring out something is missing I guess.

  • By "takes you back to the start", which path is this? I am assuming / because you begin with Volumes as a relative path. – perhapsmaybeharry Apr 26 '16 at 11:51
  • 1
    Are there other folders listed in /Volumes? Otherwise you may need to run Disk Utility first (it's in one of the menus) and mount the main drive there. – nohillside Apr 26 '16 at 11:57
  • 3
    If I understand correctly, cd OS\ X\ Base\ System takes you back to /? I suggest you follow @patrix's suggestion of mounting the main disk through Disk Utility. If you need to use the command line, diskutil mount /dev/disk0s2 (assuming disk0s2 is your main partition). – perhapsmaybeharry Apr 26 '16 at 11:57
  • 1
    Other folders are .Trashes, The external hard drive I have connected. yes, it takes me back to /. I deleted private/var folder. All hell broke loose since then. Thats why I am doing a recovery of files. – sanjihan Apr 26 '16 at 12:03
  • 2
    When booted to OS X Recovery the root of the Macintosh HD is not /, it's /Volumes/Macintosh HD/. – user3439894 Apr 26 '16 at 12:15
11

My goal was to copy files to the external hard drive. They are stored in Macintosh HD (I originally thought I will find Macintosh HD in a subfolder of OS X Base System - wrong assumption). There was no Macintosh HD in Volumes folder, because I first needed to unlock it (I use FileVault).

First you need to find the lvUUID of your Macintosh HD. Use this command:

diskutil list // lvUUID

Look for text looking similar to this:

Logical Volume on disk0s2 
4B2EFAAE-C871-4E6D-AB15-2DDE604B97CE // this is lvUUID
Unlocked Encrypted

To unlock use this command:

diskutil cs unlockVolume lvUUID #replace lvUUID by the one shown in the diskutil listing

You will be prompted with password for your user account. After that Macintosh HD will be present in /Volumes/ folder.

All thanks to klanomath for enlightening me. See full Q&A here: No Macintosh HD in Volumes folder

  • THANK YOU !!!! AHHH!!! I had a problem with kernel extension causing me to not be able to boot at all, and of course there was no easy visible way in recovery mode to mount my root fs, but this worked perfectly and was able to fix everything, THANK YOU THANK YOU AHHHH!!!!! – sMyles Dec 16 '16 at 15:36
  • If anybody need the tutorial it's at this link: smyl.es/… – sMyles Dec 16 '16 at 18:20
  • You can also mount your hard drive from disk utility, then open terminal and cd to it – BallpointBen Jun 29 '18 at 5:03
3

When booted to OS X Recovery the root of the Macintosh HD is not /, it's:
/Volumes/Macintosh HD/

To get to your Home directory in Terminal, use:

cd "/Volumes/Macintosh HD/Users/User_Name"

Where User_Name is the name of your User Account.

From there you can access your directories such as Documents, Desktop, Pictures, etc.


When booting into the Recovery Partition, the Macintosh HD does get mounted automatically and should be listed in /Volumes. If this is not the case, run Disk Utility (accessible through one of the menus in Recovery Mode) first to check the drive for errors and have them fixed.

  • upon ls-ing the folder it first throws me into when I open Terminal I can see that there is no Volumes, just .Forward and Library. I also edited my question with the result of pwd command executed right after opening the Terminal. – sanjihan Apr 26 '16 at 12:26
  • @sanjihan, It doesn't matter what directory you're in when starting Terminal in OS X Recovery! You have to navigate to where you want to be and the information I've presented in my answer re: cd "/Volumes/Macintosh HD/Users/User_Name" worked for me when booting into OS X Recovery. If your internal startup volume was not named Macintosh HD then change the command to what's appropriate. – user3439894 Apr 26 '16 at 12:34
  • Agree with you! Buy there is no Macintosh HD in Volumes. just OS X Base System and .Trashes. I thought that OS X Base System is a parent of Macintosh HD. Just found out it isnt. I will procede with First Aid on Macintosh HD. Mybe that will list it in Volumes – sanjihan Apr 26 '16 at 12:40
  • @sanjihan, If you quit Terminal and go into Disk Utility, do you see your Macintosh HD? – user3439894 Apr 26 '16 at 13:03
  • yes I do, but it is greyed out. I ran First Aid on APPLE SSD which is a parent folder of Macintosh HD. – sanjihan Apr 26 '16 at 13:12
3

For new macs using disks with APFS (Apple file system) you can simply do:

diskutil apfs unlock "Macintosh HD"

And then access it by:

ls "/Volumes/Macintosh HD"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .