0

I'm installing El Capitan on a MacBook Air that I aquired with no internal drive, so no previous OS.

I proceed through several steps fine until "Create a Computer Account".

Create a Computer Account

But it doesn't like the details I enter and shows this cryptic error box:

The name you entered can't be used.
The name is not available. Enter a different name.

The name you entered can't be used.

The worst part is that it now does not allow me to edit any of the text fields! I can click on them and drag and select them, but I cannot type new letters or delete existing letters, etc.

Is this a known problem? I can't find a solution to it via Google though I do find a tiny number of people asking about it. If not, what am I missing?

  • are account names limited to 8 characters still? (old Unix use here and never tried a longer one) – Mark Apr 26 '16 at 11:16
  • I'll try a shorter name after force restarting ... – hippietrail Apr 26 '16 at 11:17
  • There is a 20 character limit. – IconDaemon Apr 26 '16 at 11:21
  • Oddly, after I had to shut down to get out of this dead end loop, I did have the account and names I chose when it restarted. This might just be a very rare artefact of ultra-slow running speed since my OS is on a USB 2.0 stick for now... – hippietrail Apr 26 '16 at 21:52
2

I ran into this issue today. Apparently the error message is trying to tell you that there is an existing person with the same "Full Name" as you. Hence it cannot let you add another username with the same "Full Name". In my case, I was recovering from Time Machine and getting this error msg. So I just changed the full name to my last name. Was able to create an account using that and proceed further.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .