Already filed a bug in Apple's bug reporter, ID is 25949722

What I want to do is to set Canary as default browser, but when I opened system preferences, I cannot see any browsers listed.

What's wrong with my Mac (OS X 10.11.4 - El Capitan)?

enter image description here

  • Welcome to Ask Different! While this is an well posed question including the screenshot, it would be helpful if you provided the version of OS X you are running.
    – Allan
    Apr 26 '16 at 11:55
  • @Allan it's OS X 10.11.4
    – david30xie
    Apr 29 '16 at 8:55

Do you have Google Chrome (I hope so since Canary is a pre-dev Chrome release and prone to crashing)?.

Go into the Chrome settings page by typing chrome://settings and setting Chrome as the default browser (it's under the "General" tab). Once you do that, it should fix the problem you are seeing in System Preferences

  • Thank you, Allan. This should work. I understand that Canary is pre-dev release , but that's the reason I want to use Canary, I want to have test features. Also, even I use this way to make Chrome default browser, it doesn't fix the issue the browser list is empty.
    – david30xie
    Apr 29 '16 at 12:25
  • That's what worked for me. Try setting Safari as the default browser in Safari prefs (General Tab). Restart your machine then go back and try to change your browser to Canary under Sys Pref.
    – Allan
    Apr 29 '16 at 13:03
  • I don't know why, but installing Chrome again did worked! BTW, with latest Safari, there's no prefs for default browser, it's all in system preferences -> general
    – david30xie
    May 2 '16 at 8:39

It looks like you may need to rebuild the Launch Services database, which is what the Mac uses for its "what apps can open this type of file" structure.

You can either do it in Terminal, using

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user ; killall Dock

then restart,

Or Onyx (freeware) can do it for you - Maintenance tab > Rebuilding - check just the first box & execute.

  • I tried both ways, and neither of them worked
    – david30xie
    Apr 26 '16 at 9:54

I deleted the Opera browser and it solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .