0

I have set up two IMAP email accounts on 1 Iphone. Both accounts are set to send via their respective outgoing email server. The first account sends emails properly. The second account tries to send outgoing email via an old mail server that no longer exists.

I have deleted the 2nd account multiple times and re-added it from scratch each time but it still insists on sending via the old non-existent mail server. Is there some other place where this is stored? Any suggestions on how to fix this?

  • 1
    Is this the default iOS email app or a 3rd-party app? – fsb Apr 25 '16 at 20:51
  • Default IOS Email – John S Apr 26 '16 at 19:28
1

If using the default mail app,

Settings > Mail, Contacts, Calendars > (pick account) > (click account again) > Outgoing mail server

You should be able to configure which SMTP server will be used for the account.

  • Was this helpful to you? – Tyson Apr 26 '16 at 18:05
  • I already have three outgoing servers configured for three email accounts. One is Gmail which is working fine. The second is an IMAP account which is the problematic account and the Third is an IMAP account for a third email account. The third one is working fine also. I have deleted and recreated the second account multiple times. – John S Apr 26 '16 at 19:19
  • I think it's gotten changed on you, the path above will lead you where you need to check if you're using the default mail app – Tyson Apr 26 '16 at 19:21
  • I have gone in there for all of the accounts and verified that they are set correctly. The weird thing is that the server that it is trying to send outgoing to no longer exists and I can not find it in any of the settings. So it seems that there is yet another place that is persistently holding this setting. – John S Apr 26 '16 at 19:24
  • Now i've gotten a new iPhone and have restored the iTunes backup from my old to new phone and the problems now happens on the new phone too. – John S Jun 17 '16 at 5:04
1

I was having the same problem. It turned out that I had not provided a password to send email - it was set to [optional]. Once I entered the password for the smtp server, it switched to sending mail using the new account's smtp server. Very quirky that the mail app tries to send using an old account's smtp server instead of providing a sensible user error message. Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .