0

I am trying to create a boot disk for an older MacBook Pros that I have (MacBookPro 11,1 running OSX 10.9.5) which I plan to then boot from a newer MacBook Pro (MacBookPro 12,1 running OSX 10.11.4). These machines have essentially identical hardware with only 1 difference - the Pro 11,1 has a 500GB SSD, and the Pro 12,1 has a 1TB SSD.

However, I have run into some problems, and I am stumped. Any advice would be very much appreciated.

Here is what I have done:

(1) Create a Carbon Copy Clone of OSX 10.9.5 (Mavericks) running on my MacBook Pro 11,1 using the instructions on the Carbon Copy Clone website. The backup disk in this case is a SanDisk Extreme 500 Portable SSD.

(2) Test that the machine from which I created the clone (MacBookPro 11,1) can boot from the SSD. This works absolutely fine, with no hiccups.

(3) Attempt to boot from the SSD on the newer MacBook Pro 12,1 (which is running OSX 10.11.4 - El Capitan). This fails; all that I see is the 'No Access' Symbol

(4) Update the /System/Library/CoreServices/PlatformSupport.plist file on the SSD boot disk to match that on the MacBook Pro 12,1 based on advice offered at this URL. Now when I attempt to boot from the SSD, I get slightly further - in fact I get past the 'No Access' screen, and I make it to the expected grey screen with the Apple logo; however, at that point things simply hang (in fact the spinning wheel never appears below the apple logo like i would expect).

I've tried some other things. For example:

  • I tried again from scratch, wiping the disk & re-cloning, several times in fact, just to verify I wasn't missing something obvious.

  • I ran a 'Repair Disk' in disk utility on both the drive I want to clone, as well as the SSD backup disk. However, i still get the same problems.

  • To eliminate the possibility that this has something to do with the disk itself, I created a clone of the MBP 11,1 on a western digital drive that I have laying around, and ran through steps (1) - (4) above. The Western Digital behaves identically to the SanDisk SSD, leading me to believe that these problems have nothing to do with the External Drive itself.

Any help would very much be appreciated - The problem suggests that there is some compatibility issues with the Pro 11,1 and the Pro 12,1, given that the SSD boots fine from the Pro 11,1. Anyway, I have been reading many forums, but I am stumped.

1

You say the only difference between the two models is the size of the drive. This is an incredibly naïve statement. Although, I have not checked in depth, it would be a safe bet next model differs in hardware beyond the drive size.

Let's look at the chronology.

  • OS X 10.9 is released on November 22, 2013
  • MacBookPro11,1 is either a Late 2013 or Mid 2014 model. Should be shipped with OS X 10.9.
  • OS X 10.10 is release on July, 24, 2014
  • MacBookPro12,1 is either an Early 2015 model. Should be shipped with OS X 10.10.

When OS X 10.9 was released, most likely this version did not contain the software (drivers) for Macs not yet shipped. So installing this operating system on a future MacBookPro12,1 model should result in failure.

The opposite would likely succeed. You should be able to take OS X 10.10 from a MacBookPro12,1 and run successfully on a MacBookPro11,1.

How about upgrading OS X on the older machine before running on the newer machine?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .