0

I had Windows 10 Bootcamp on my MacBook Pro 15" 2015. I just tried to remove the Bootcamp with Bootcamp assistant by clicking "restore" and it gave me an error saying "The disk cannot be partitioned or restored to a single partition."

So I followed instructions given by this answer and I deleted the Bootcamp partition using Disk Utility.

The partition was successfully deleted and there was 200GB of unused space. I tried to merge it with my OSX partition and it gave me an error. Forgot what type of error exactly, something about one of partitions being broken (wrong amount of blocks or something?)

Now the problem is that the 200GB of unused space (previously used by Bootcamp) just disappeared. Nowhere to be seen.

enter image description here

What can I do to fix this? How can I get my OSX partition back to the original 500GB?

diskutil list

enter image description here

diskutil cs list

No CoreStorage logical volume groups found

sudo fdisk /dev/disk0

enter image description here

sudo gpt -r show /dev/disk0

enter image description here

  • If you can edit your question and post the output from the following Terminal application commands, I will try to simulate your conditions. If successful, I will post a solution. diskutil list, diskutil cs list, sudo fdisk /dev/disk0 and sudo gpt -r show /dev/disk0. These commands will not change your computer. Some may ask for your login password. This is normal. – David Anderson Apr 24 '16 at 22:57
  • Maybe try the Disk Utillity in the Recovery HD. (cmd + r) – bret7600 Apr 24 '16 at 23:39
  • @DavidAnderson I edited my question and added the commands. Thanks! – Matt Apr 25 '16 at 6:44
1

You show in your posted image that the partition is encrypted. I was unaware a partition could be encrypted without using core storage. Anyway, I believe the correct command to fix your drive is given below.

sudo  diskutil  resizevolume  /dev/disk0s2  R

The command should move /dev/disk0s3 to the bottom of disk0 while resizing /dev/disk0s2 to maximum size. I am not sure if the sudo prefix is required.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .