I updated OSX last night to El Capitan and after the update, and restarting my iMac(2014) a few times, I cannot sign in with my Apple ID.

The initial restart gave me the error: "This action could not be completed. Try again." I assumed I had forgotten my password, so I went through the procedure of resetting my password. I was then allowed access.

When I then tried logging in to another service requiring an Apple ID (Mac App Store in particular), I get the error "This action could not be completed..."

Restarting my machine does nothing. Should I revert to an older version of OSX?

enter image description here

  • The error message indicates that it cannot connect to the store for some reason, not that your username/password is invalid. Have you confirmed that your have Internet? – Allan Apr 24 '16 at 12:26
  • Hi Allan, my internet connection is fine, I've managed to connect via the web, its just when I try to use services like the mac app store or iCloud. This only started happening after I upgraded to El Capitan, so I'm assuming there's something up there. Maybe something on Keychain isn't working as it should? – Emile Esterhuizen Apr 24 '16 at 12:39
  • Can you post a screen shot of the error in your original question? Shift-Command-4 is the key combo to do a area screen grab. – Allan Apr 24 '16 at 12:47
  • Screenshot added, I'm hoping to avoid something like what was posted in this question, I'm also reluctant to start messing with file system permissions like in this question – Emile Esterhuizen Apr 24 '16 at 12:54
  • *SOLVED(potentially)... I took a wild stab in the dark that iTunes was the problem, and so updated iTunes first, then attempted a sign in... once the iTunes sign in was successful it seems that everything else is now able to sign in... at least the Mac app store. – Emile Esterhuizen Apr 24 '16 at 14:56

Execute the following commands in Terminal:

sudo mkdir -p /Users/Shared
sudo chown root:wheel /Users/Shared
sudo chmod -R 1777 /Users/Shared
  • 1
    That saves me a day!!!! – Gavin Oct 15 '16 at 21:34
  • 1
    No words...I have no idea how this is related, but saves my XCode sign-in problem. – Leo Oct 21 '16 at 21:57
  • 2
    Spent an hour with Apple support - could not fix it. But this little advice solved the problem. Thank you! – Evgeny Minkevich Dec 13 '16 at 2:48
  • I guess it wan't a good idea to remove Shared folder from Users in the first place :-) – Mikhail Kalashnikov Jan 21 '17 at 13:16
  • I've put up with an annoying "sign into iCloud" popup on my Mac for months, with the password not working and nobody at Apple able to help. Couldn't update Xcode either via the App Store. This solution just fixed both of those problems. Thank you! – TheBestBigAl Jun 27 '17 at 10:08

I ended up updating iTunes then signing in, after the update completed and a restart. Once the iTunes sign in was successful everything else was able to sign in. Hope that helps someone.


I don't recall where I found these, but the following commands in Terminal worked for me:

sudo mkdir -p /Users/Shared
sudo chown root:wheel /Users/Shared
sudo chmod -R 1777 /Users/Shared
  • 1
    This is the same answer as this one - it doesn't add any value and should be deleted. – Glorfindel Apr 21 '17 at 20:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .