1

My friend has developed an app and sent me the .ipa file. He wants me to install it on my phone. So I went into iTunes and dragged the ipa into the app section. Then I connected my phone to my computer, and made sure iTunes could access it. After that I went to the app section of my device info. I saw the ipa file I've imported earlier followed by an install button. I clicked on the install button and hit the apply button on the bottom. Now the app finishes copying to my phone and it does display properly in the device's app info's home screen section. But it is not appearing on the actual device. I tried restarting the phone, but that didn't help. I looked back at the row that displays the app, the button changed from 'install' to 'installing' but never changed to anything else. Any ideas?

EDIT:

I went into the storage settings and found out there is 40GB of storage left; after I press install it has 39.9GB left, so the app is definitely installed but just not displayed, I can't see it in the Spotlight search either.

1

This IPA application may not have signed for your phone. So you can not launch it in a normal way. Resigning the IPA or patching the launchd in your phone with some packages like AppSync may resolve this.

2
  • My phone is not jailbroken, so I can't patch launchd. I tried resigning the IPA with my own developer account, still doesn't appear on home screen. On iTunes it displays as normal. – Tom Shen Apr 22 '16 at 11:33
  • OK, it seems like I needs to reset my developer profile's device list, now the app appears for a brief second and them disappear. – Tom Shen Apr 22 '16 at 12:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .