23

I have a brand new 2015 mac, el capitan 10.11.4. The wifi constantly drops. I have re-installed a fresh el capitan, reset SMC, created new wifi profile/location with google dns, safeboot, updated router firmware, and update router channel. None of these things have fixed the constant dropping. The dropping mostly happens when I open multiple tabs or download multiple things at once. Any recommendations? How can I analyze the dropped connection report?

  • Anyone else have a possible solution? – John S. May 8 '16 at 15:47
  • Does it work with another device (i.e. Mac, PC, phone)? or with another router? – user151019 Aug 31 '16 at 14:01
  • For me it works at work, but doesn’t work at most other routers. – Misha Reyzlin Aug 31 '16 at 16:07
20

This fixed it for me:

  • System Preferences → Energy Saver → Battery Power: Uncheck “wake for network access”
  • System Preferences → Network → Advance → TCP/IP: Configure IPv6 – select “Link-Local only”

Found the above fix in the comments of this article: http://osxdaily.com/2015/10/16/fix-wi-fi-problems-mac-os-x-el-capitan/

  • 2
    This fixed the problem for me.. How crazy is this problem? What a nightmare for MAC users. – cwiggo Aug 10 '16 at 10:34
  • 1
    It didn't solve for me. Trying the next answer. – Flavio Wuensche Sep 27 '16 at 5:07
  • @FlavioWuensche I didn't say it was the definitive answer and it has helped some people so no need to down vote. – Jack Sep 27 '16 at 16:06
  • I didn't downvote. I actually upvoted. And thanks for sharing :) I've read about an interference with bluetooth devices so I'm trying not to use my bluetooth keyboard and trackpad devices today as an experiment. It seems to work so far. Problem is, if that's the real problem, how can I use my devices? Is there any fix for that? – Flavio Wuensche Sep 28 '16 at 20:31
  • Ok, it isn't the bluetooth neither! I'm geting sick of it. I'll format my Mac now and hope it is a software issue. If it works, great! If not, I'll have no choice but to miss my last Chromebook :/ and visit an Apple Store. – Flavio Wuensche Sep 28 '16 at 21:15
4

I had a fleet of MacBooks doing the same thing. What I eventually found out is that OS X has created a virtual interface called awdl0 or Apple Wireless Direct Link. I won't go into the details of how it works because there is a really good explainaition here.

What we found was that if this interface was active we would have wifi dropouts and performance issues. If the interface is disabled we had no issues with wifi.

It was easily testable by first having it enabled and doing a speed test, then disabling it and doing the same speed test. The second speed test with it disabled would easily get double the bandwidth.

If you look around the net a lot of people are saying that it is causing wifi channel interference. So it does something along the lines of creating a second wifi connection on the same channel. The two connections (your main wifi and awdl0) are interfering with each other and cancelling out.

Solution

Try this first, open Terminal and type

sudo ifconfig awdl0 down

Try out your Wifi now and see if that helps.

If it does, please note that this fix will not remain between reboots. You'll have to add something to a startup script or create a task that turns it off on bootup.

Word of Caution

This interface is used to create connections between Apple devices like MacBook to AppleTV or using AirDrop. I am going to caution you that these services may not work after disabling the awdl0 interface.

We have a bunch of AppleTVs that still work fine with it disabled. As far as I can tell it will use the Wifi to connect instead of Bluetooth (I could be wrong about this)

  • Unfortunately this still does not fix the problem. I was really hoping that it would. Is there any chance that I can post the wifi crash logs here and get some interpretation? There are a ton of different files in the wifi log so I dont know exactly what to post. – John S. May 2 '16 at 14:22
1

Upgrade to macOS Sierra.

Of course I didn't try it first. I've had already done so many things. I'll list all of them so you can try as well before going to the final solution that worked for me. Why don't I recommend doing it first? Because as some of you might already experienced, new OSs are always tricky in terms of compatibilty. Some of your programs might stop working, so go ahead and try these first:

  • The first suggested receipe will change your DNS servers to Google ones for no reason. The second receipe can't fix a software problem. The 3rd one can't fix a software problem either, but will need a full backup and a full install == 4 hours wasted. – dan Mar 27 '18 at 15:49
0

I am also having Wi-Fi issues (for months) with MBP 2014 and I found a temporary solution to the problem. I have tracked down the problem to be or kernel or driver implementation bug with 802.11n (the important info here is the "n"). I have an Airport Express and inside the configuration for Wireless (Radio Mode) you can choose for 802.11n with 802.11b/g compatible and a lot of other options. if you have one two, before clicking the dropdown hold ALT(option) to show more options and select 802.11b/g only, if not look for this inside your router/access point. You can check what type of mode you are using holding ALT(option) and clicking on the Wi-Fi icon at the menubar (the same place as the clock), at the bottom you will see PHY Mode, and check there the mode you are connected if is 802.11n or 802.11g. You need to be using 802.11g, and see if your connection will drop.

I am using 802.11g for a while now and no driver crash. When the driver crashes the only way to reset automatic is to restart the network interface and turn it on again, that's why the Mac do it, but when it returns the bug continues (it can't communicate to the router and no connection is made) and you have to turn Wi-Fi off and on. But it continues because there is a problem with 802.11n. So we have to wait for Apple to fix it and I have been waiting for a long time and no solution yet!

Just to add info, I have tried everything you can imagine, El Capitan fresh install, do all sort of configuration, disable energy options and etc. but nothing seemed to work for me. (even the AWDL)

Please give me a feedback if this works for you. Thanks.

  • This does not fix anything either unfortunately. I have come to the conclusion that I can simulate an internet drop by having a really high app usage. Whenever I use external monitor, powerpoint, preview, and video on chrome all at once, it will cause a internet drop. Any recommendations on how to diagnose this? – John S. May 22 '16 at 18:47
0

I’ve had trouble with WiFi dropouts for months, even though my MacBook Pro (with OS X 10.11.6) is no more than 10 feet from the WiFi router; my phone was able to see the network consistently. I tried every possible fix I could find on the Internet, with only temporary improvements. It was frequently unusable, but I found that I could unplug the monitor, take the laptop downstairs, and it would work fine.

In my office, I’ve been keeping the laptop closed while using separate keyboard and monitor. Now I find that if I leave the laptop lid open while using the monitor, it seems to be working well. I suspect the system was putting the WiFi to sleep because the lid was closed, even though the machine and network were in use.

  • Welcome to Ask Different. While this is a good description, it doesn't really answer the OP's question. As it stands, it's more of a comment than an answer. Consider rewriting so it provides and answer – Allan Jul 28 '16 at 21:14
0

I reset both the PRAM and SMC. That appears to have done the trick.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .