4

Recently the keyboard and trackpad on my 2015 13" MacBook Pro have stopped working. This is the second laptop to do this, the same issue happened about 6 months ago and Apple gave me a new one when they could not figure it out.

The issue usually starts with force touch not working then progresses to the keyboard and trackpad not being recognized at all. Currently the power button works and force touch works but all other keys and the trackpad don't work.

When this happens there are a lot of errors in the console regarding the AppleHSSPIController.

4/21/16 6:56:47.000 AM  kernel[0]   Error: AppleHSSPIDevice::start failed to get device descriptor
4/21/16 6:56:47.000 AM  kernel[0]   Error: AppleHSSPIController::_enumerateDevice Start failed
4/21/16 6:56:47.000 AM  kernel[0]   Error: AppleHSSPIController::_handleEnumerationFailureGated Giving up on device

You can see the full log here: http://pastebin.com/r8x9S46K

  • Welcome to Ask Different! I can't see where you're asking a question. Can you indicate, as specifically as possible, what type of assistance you're looking for? Here's some info that will help you create good questions: apple.stackexchange.com/help/how-to-ask - From Review - – fsb Apr 21 '16 at 13:43
  • Great question with great degree of detail. Can you eventually post how you got it fixed? Did you have the keyboard and touchpad exchanged at the apple store? – Lukas Jul 13 '16 at 9:39
  • Got exactly the same problem with the same logs. I also think it's hardware related, my guess is that a glitching cable makes the osx driver lose sync with the keyboard/touchpad hardware and after that only a reboot will get it in tune (assuming the glitches are transient - if it's really broken, a reboot won't help of course). Going to Apple with it this week. Annoyingly, they replaced the whole topcase for me last year due to similar problems :/ – BjornW Dec 31 '17 at 11:56
1

Since I ran into the same problem and this comes up on Google, I will provide an answer, even if there is no question.

  • When my keyboard and touchpad stopped working, the power button was still ok.
  • Resetting NVRAM did not help.
  • Using an external keyboard and mouse was fine.

Typing sudo dmesg | tail on the command line was showing similar messages:

AppleHSSPIController::_enqueueSPICommandGated SPICommand timed out. Interface 208, transactionType 64, frameNumber 0
Error: AppleHSSPIDevice::_DoDescriptorRequestGated Failed issue request error: 0xe00002ed
Error: AppleHSSPIDevice::getDeviceDescriptor Failed to get descriptor with error 0xe00002ed
Error: AppleHSSPIDevice::start failed to get device descriptor
Error: AppleHSSPIController::_enumerateDevice Start failed
Error: AppleHSSPIController::_handleEnumerationFailureGated Failed to enumerate the device. Resetting the device and trying to enumerate again. Attempt:1
IO80211AWDLPeerManager::setAwdlOperatingMode Setting the AWDL operation mode from AUTO to SUSPENDED
IO80211AWDLPeerManager::setAwdlSuspendedMode() Suspending AWDL, enterQuietMode(true)
AppleIntelLpssGspi1::calcSpiClockParams: fSysClockPeriodPsec 10000, spiClockPeriodNsec 125
Error: AppleHSSPIController::doSPITransfer ERR received from device

I brought it to the local Apple support partner. They first tried it by updating the touchpad controller software. Since that did not work either, they changed the HSSPI cable.

  • Is this a "great question" as you commented to the OP or is there "no question" as you prefaced in your answer? These two statements seem to contradict each other. – Allan Jul 18 '16 at 14:35
  • @Allan, possibly I might just claim in retrospective, there was irony involved in my original comment. :P – Lukas Jul 19 '16 at 7:10
1

Most likely, your internal keyboard and trackpad has failed.

The "Internal Keyboard/Trackpad" is a USB device, so there is no special controller or circuitry involved on your logic board. If you plug in an external USB keyboard/mouse and everything works, then it's definitely not your logic board as the symptoms would be present then as well.

enter image description here

As for the cause, it could simply be a manufacturing defect of the keyboard, trackpad, or some other related component. Without actually having the component to bench test, it would be impossible to guess what exactly is wrong with it.

However, the trackpad and keyboard are technically separate components even though they are part of a master assembly called the "top case." If you have ability and resources, you can open your MacBook Pro and disconnect either the keyboard or the trackpad. If the symptoms go away, you will know that is the component has failed.

enter image description here

If not, do the opposite and see if the results differ. You will need an external mouse and keyboard to do this test.

1

I ran into the same problem with my Retina, 13-inch, Early 2015 MBA, in order to save people some time I'll post my solution here.

First I reset smc, pram, vram, updated the OS, reinstalled it, installed it on an external hard drive but nothing worked. So I thought it is a hardware problem.

As last attempt I started the computer in the safe mode holding down shift while starting up. Nothing was changed but after restarting in the normal mode suddenly both keyboard and trackpad were working again.

I hope this helps you too.

0

I'd same issue since last week: macbook pro, 13'' early-2015, retina. Internal keyboard and trackpad stopped responding at all but external usb or bluetooth connected keyboard/trackpad worked well. /var/log/system.log was showing recurring messages like below every time I restarted machine.

Dec  3 00:48:22 foomac kernel[0]: AppleHSSPIController::_enqueueSPICommandGated SPICommand timed out. Interface 3, transactionType 64, frameNumber 0

Dec  3 00:48:22 foomac kernel[0]: Error: AppleHSSPIController::doSPITransfer ERR received from device

Dec  3 00:48:24 foomac kernel[0]: AppleHSSPIController::_enqueueSPICommandGated SPICommand timed out. Interface 3, transactionType 64, frameNumber 0

Dec  3 00:48:26 foomac kernel[0]: Error: AppleHSSPIController::doSPITransfer ERR received from device

Dec  3 00:50:45 foomac kernel[0]: Error: AppleHSSPIController::doSPITransfer ERR received from device

As mentioned in Allan's post above, I think it was SPI device under hardware that was faulty and not the USB device. Apple USB device only shows up external and not the internal keyboard/trackpad, when connected.

I sent macbook for repair to AppleCare under warranty, and got it returned with change in Trackpad cable (part number - 631-01309). Cost $ 0! Make sure to back up the entire system using Time Machine as very likely repair person will wipe out your system and resets to factory default. S/he kept the same OS version though for my macbook (10.11.6).

Following restore from time machine, my macbook seems to be running ok and culprit HSSPIController error is gone now. Following are system.log messages with reboot of system.

Dec 17 08:40:45 localhost kernel[0]: AppleHSSPIController::start Start Succeeded
Dec 17 19:10:54 localhost kernel[0]: AppleHSSPIController::start Start Succeeded
0

I had the same exact issue, same model (MacBook Pro Retina 13-inch Early 2015). I replaced the trackpad cable and it resolved the issue. However, now the battery is not charging/operating properly, and the computer will only function when it is plugged in to AC adapter. So now I am trying to figure out why the battery isn't working after trackpad cable replacement.

You must log in to answer this question.

protected by Community Jun 17 '18 at 16:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .