2

I'd install rEFInd in my Mac Mini 2,1. It has a OS X Lion bootable partition and a Windows 10 install ntfs partition. I tried to boot from the ntfs partition but the Windows Installer won't run, only a black screen with a DOS cursor blinking. Now I can't make the rEFInd boot menu show up again. I turn on with "alt" key or "c" key pressed but Mac Mini ignores and (appears to) try to boot from ntfs partition again...

Any idea before I have to open the Mac Mini physically?

1
  • Why do you have rEFInd installed? You do not need this for OS X or Windows 10. Apr 21, 2016 at 21:30

1 Answer 1

0

To get started, try to reset NVRAM:

Shut down your Mac. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. Turn on your Mac. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound. Hold these keys until the computer restarts and you hear the startup sound for a second time. Release the keys.

Resetting NVRAM

(If the rEFInd installation was performed something like sudo bless --mount / Volumes / ESP --setBoot --file /Volumes/ESP/efi/refind/refind_x64.efi --shortform, and the boot volume information was recorded in NVRAM).

2
  • I could not reset NVRAM - strange! However there was an error in rEFInd install, it appears to be installed in the Mac OS X USB install, instead of main HDD. I remove it, boot from HDD and did install rEFInd again and now it is showing up by boot + Option. Cant mark u as useful so will mark as solved because this investigation lead to the solution. Other USB flash drives as Win or Ubuntu don't show up in rEFInd list, but this is another problem... thanks!
    – Gustavo
    Apr 22, 2016 at 1:19
  • Installing rEFInd Manually Using Mac OS X:[link] (rodsbooks.com/refind/installing.html#osx)
    – cave-canem
    Apr 22, 2016 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .