0

As of today, I'm suddenly unable to view any SMB shares on my macbook pro (mid 2011 13" model, El Capitain 10.11.4).

Everything worked fine yesterday, but today I can't connect to ANY windows file share systems. I have to load Windows XP in Virtualbox and copy stuff across that way.

I've looked at all the other answers, and this isn't because of some program (I have none running atm), nor is it due to cloud sync (I have it disabled) or time machine (I never use it).

Everything worked (well, as good as can be expected with file sharing on a mac), and now suddenly nothing works. Using the IP address directly doesn't help. Rebooting didn't help. Restarting the other machines didn't help. Disconnecting and reconnecting WIFI didn't help. And of course, the computer doesn't give any kind of error code to help track down the problem. Just "There was a problem connecting to the server".

The servers still do show up in Finder (even after rebooting). I just can't connect to them. Actually, it does connect to them long enough to ask how I want to log in, but then it pukes and shows that error.

-1

work around ... add authentication to your smb.

  • Can you elaborate on how to do that? – nohillside May 1 '16 at 6:43
  • one smb server add users (smbpassword -a username). Under share folder in smb config add valid user = username. – asterion May 1 '16 at 6:45
  • 3
    Expand in your answer, not in the comments – Allan May 1 '16 at 9:28
  • smbpassword is not a valid command – Tiago Jul 13 '18 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .