19

By default, clicking on an email address from another mac app (such as Slack) launches the Mail.app application in a compose view to that email address.

I would like to disable this - I never use the Mail.app and most times I encounter an email address I'd like to copy/paste it somewhere else, not compose an email to that person.

Is there a way to disable that behavior?

1
  • It's going to open something, whatever your default mailer is. Right-click/Copy Link if you don't want to open a mailer.
    – Tetsujin
    Apr 20, 2016 at 18:07

2 Answers 2

11

Notwithstanding any sneaky Terminal commands I know not about, OS X will always have the need to open some app upon clicking an e-mail link. Literally any app of your liking will do.

Such an app might be an app you don't mind being opened. Like… the Finder!

  1. Open Mail Preferences and go to the first tab, General. Choose the pop-up menu for Default email reader and pick Select….

    Picking another e-mail client

  2. Choose Macintosh HD (or whatever you've renamed your boot volume to) → System → Library → CoreServices → Finder.app.

    Choosing the Finder

  3. Try it out! (I can't post mailto: links here though. 😕)

If you work with spaces or full-screen apps, clicking a mail link might switch spaces. But at least no apps are launched. On my computer, not even a new Finder window is opened.

8
  • 1
    This works for changing the email reader but mailto: links still open the Mail.app. I found a working answer here: superuser.com/questions/1067771/…
    – johncorser
    Apr 21, 2016 at 18:33
  • The "reader" part of the option is there because it's hard to name settings for the average user. What else could that setting do? (Compare with the "newsreader" setting for RSS in older Safari versions.) In any case, it did work on my El Capitan, but there seems to be a LaunchServices cache bug which accidentally reverts changes to the setting—the workaround is /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user and a reboot. The linked answer might be better though. Apr 21, 2016 at 22:54
  • 1
    @johncorser I have mine set up to open the browser app I use. For Firefox this makes the mailto: links do nothing.
    – farmerjoe
    Aug 30, 2016 at 17:29
  • @johncorser I got the same results as farmerjoe using Chrome.
    – intcreator
    Aug 7, 2017 at 23:00
  • This unfortunately doesn't work for me. In the dropdown I can only select Mail app and if I choose anything else in applications, it seems to reset every time I close Mail app. I'm on El Capitan. Anyone has any workaround? Aug 19, 2017 at 16:17
4

Had the same problem here, but decided to do a little more. Instead of opening the "Finder" app, I used the "Automator" to create an application that literally does nothing!

The key is to save the Automator project and them put a command on it that will close the same Application you're editing! Them just set it as the default mail application. This way you won't have to worry about some application opening when you click in the address.

I made a simple tutorial with some screenshots if you want to check it out:

2
  • Nice. How would one create an automator script/app that tasks the clicked email and copies it to the clipboard?
    – Moritz W
    Nov 4, 2021 at 10:51
  • incredible! thank you so much! been annoying me for years! this was a really slick fix :)!
    – Lopey Tall
    May 9 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .