0
  • mac os 10.11.4
  • mail app 9.3

Had a working exchange/office365 account. Did not work anymore, used safari to go to office365.com and it appeared that I was required to change my password. So I changed it and can login on www.office365.com So the mail.app tells me to change the password, but when I hit save I get: account already exists.

So I removed the account from the settings --> internet accounts. closed mail.app, rebooted the mac and tried to add a new exchange account. But again "account already exists"

This seems similar to Mac Mail - Account already exists error when adding gmail but iCloud is on a totally different mail account and even a different domain. Before I removed the exchange account, I manually updated all office365 passwords in the keychain. But that did not work either. Mail.app kept complaining.

Please do not suggest to move to outlook. I have outlook installed, but my boss (owner of the macbook) want to stick to the default mail.app

1

I had the same thing happen to me this evening after updating my Office365 password.

What worked for me was to open my desktop Outlook App and send myself a test email. Outlook was then prompted to ask me to put in the password. After adding the password to Outlook and sending the test email, I then went back to my Mac Mail and received my test email there. I also checked the Outbox in Mac Mail, which had three emails waiting to send. I double-clicked on the first one and then all three emails sent.

  • Thank you, but the question was 2 years old. I manually fixed it back in april '16. I think it's fixed in current versions. – JP Hellemons Jun 8 '18 at 7:21
0

I have fixed it.

  • Went to ~/Library/Mail/V2
  • opened the plist xml file in textwrangler
  • removed all XML nodes containing the office365 accounts
  • saved the file
  • Went to ~/Library/Mail/V3
  • deleted the folders related to the office365 accounts
  • opened keychain app
  • searched for office
  • removed all entries related to the office365 accounts
  • added the account at the settings -> internet accounts page

It works then. Strange that removing the account does not clear folders, and xml nodes in a settings file etc. and actually breaks re-adding the account. Perhaps someone can explain why this happened

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .