0

I download Apache James email server on my Mac. I extracted the zip to a "james-2.3.2" folder. When I run "./james-2.3.2/bin/run.sh" I get a "Permission denied".

I tried doing a chmod 755 on the run.sh but it still gives me an error (something about permission denied regarding a phoenix .sh file).

I expect I'm doing something fundamentally wrong. Any help is appreciated!

rob

1

You have to set chmod 755 for all the *.sh files in this directory. For that you could run

find ./james-2.3.2 -type f -name '*\.sh' -exec chmod +x {} \;

This command will look for files which end with .sh and sets the executable bit (okey, there are only two, the run.sh and phoenix.sh)

But you still have to set JAVA_HOME otherwise james will complain. And you have to run it as 'root' user since it the application will listen to a port < 1024. For me the following let me run james:

sudo JAVA_HOME=/Library/Java/Home ./james-2.3.2/bin/run.sh

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .