0

I have a MacBook 2011 running OS X 10.11.5, 16GB RAM, 512GB SSD Drive. Today when I am restarting my computer, I accidentally pressed Cmd+R while booting. Now I try and restart my computer, it shows this:

Boot up error

Now I tried going into recovery mode then disk utility, it does not allows me to do first aid on the disk Macintosh HD. I run fsck on Terminal in Recovery Mode as well. Still it says disk is fine. Now I wondered if it is the problem with the memory stick, so I removed the memory stick and plug the, back in, same problem. Now I tried pressing option at boot, then select Macintosh, before hitting enter I pressed cmd+s. A black screen appear then and this error was displayed on the screen:

Error loading kernel cache (0xe)

Now I am wondering what is the problem now and where should I debug next?

Thanks.

EDIT:

I tried removing the disk from my computer and connect it as external, doesn't work, same error.

1

first, try to reset nvram and smc

https://support.apple.com/en-us/HT204063

https://support.apple.com/en-us/HT201295

however, to rebuild the dylib cache

sudo update_dyld_shared_cache -force

and the boot (kexts) cache

sudo kextcache -system-prelinked-kernel
sudo kextcache -system-caches
sudo kextcache -update-volume /
sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions
  • I can't boot into the system, so I can't run these command. I tried resetting both NVRAM and SMC – Tom Shen Apr 18 '16 at 11:26
  • 1
    you can execute those commands in Terminal in Recovery Mode as you did for fsck. otherwise try to boot from a secondary (external) hd with OS X on it – user180055 Apr 18 '16 at 13:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .