1

El Capitan allows switching workspaces in Mission Control view (which shows an overview of all windows) by using 4-finger swipe left/right gesture. However, when invoking Mission control from fullscreen mode, and then swiping left/right, the spaces seem to visually slide in the wrong direction, which is very irritating.

For example, if there are 3 spaces (desktop1, desktop2 and fullscreen application, in that order), then swiping up from fullscreen view followed by swiping left twice, would result in switching to desktop2 and then desktop1, which is correct, but visually, the desktop background would slide first to the left, and then to the right (instead of sliding to the left twice). Just to clarify, this is not related to 'natural scrolling direction' option of trackpad. The problem is that the animation is inconsistent when moving between spaces.

Does anybody else experience this problem or knows how to fix it?

1

Check that under System Preferences > Trackpad, "natural scrolling direction" is enabled.

Not having this option enabled would cause the screen to follow the exact direction your hand is swiping along the trackpad, and not the natural direction I assume you're used to.

NB: I'm not sure of the exact term for natural scrolling but I'll update my answer when I can be.

  • Thank you for your response but this is not related to natural scrolling direction. The problem is that the animation is not consistent when switching desktops, e.g. swiping left twice when in mission control view, would result in desktop background (visually) sliding first to the left and then to the right. – Alex Apr 18 '16 at 9:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .