1

I have an early-2015 MBP running 10.11.3 and I keep having my internet connection drop when I am connected to certain WiFi networks. The temporary solution is to disable and then re-enable WiFi, but this gets very tiresome. It has been occurring more frequently recently (~15min → 5min).

So far, this has only happened at my home and at my cabin - it's fine on other networks.

I usually get an error in Chrome along the lines of: This webpage is not available DNS_PROBE_FINISHED_NO_INTERNET

However, I have tried multiple different DNS configurations, so this does not appear to be the problem.

Other laptops and my Galaxy S6 connect to these routers without problem.

Any ideas?

EDIT: Just got this error result earlier:

Your computer is offline. DNS_PROBE_FINISHED_NO_INTERNET

1

I am also having Wi-Fi issues (for months) with MBP 2014 and I found a temporary solution to the problem. I have tracked down the problem to be or kernel or driver implementation bug with 802.11n (the important info here is the "n"). I have an Airport Express and inside the configuration for Wireless (Radio Mode) you can choose for 802.11n with 802.11b/g compatible and a lot of other options. if you have one two, before clicking the dropdown hold ALT(option) to show more options and select 802.11b/g only, if not look for this inside your router/access point. You can check what type of mode you are using holding ALT(option) and clicking on the Wi-Fi icon at the menubar (the same place as the clock), at the bottom you will see PHY Mode, and check there the mode you are connected if is 802.11n or 802.11g. You need to be using 802.11g, and see if your connection will drop.

I think this answer your question, why in some places your Wi-Fi works (using 802.11g) without a problem and others you get drop (802.11n) connections.

I am using 802.11g for a while now and no driver crash. When the driver crashes the only way to reset automatic is to restart the network interface and turn it on again, that's why the Mac do it, but when it returns the bug continues (it can't communicate to the router and no connection is made) and you have to turn Wi-Fi off and on. But it continues because there is a problem with 802.11n. So we have to wait for Apple to fix it and I have been waiting for a long time and no solution yet!

Just to add info, I have tried everything you can imagine, El Capitan fresh install, do all sort of configuration, disable energy options and etc. but nothing seemed to work for me.

Please give me a feedback if this works for you. Thanks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .