4

Sample numbers file

enter image description here

B4 contains CONCATENATE(B2,B3)

In the file above, I am getting syntax error on B4, despite the formula seems correct. Can anyone reproduce the problem? How can I solve it?

MacBook Air, OS X Yosemite (10.10.5), Numbers version: 3.6.1 (2566)

5

Some locales use semicolon as a separator for parameters in formulae, such as Turkey. You can check this by using a comma after the first parameter, then clicking a cell. If you see a semicolon being inserted alongside the comma you should use a semicolon as a delimiter.

                                

This feels like a bug. Copy-pasting the cell shows the syntax error, but copy-pasting the contents of the cell (the formula itself) works fine, alongside me retyping the formula. You can provide feedback to Apple here:

  • I managed the make it work. Instead of putting comma as the separator of arguments, putting semicolon worked. But were you able to make it work using comma? – Utku Apr 16 '16 at 17:13
  • @Utku Yes, what locale is your computer set to? – grg Apr 16 '16 at 17:14
  • I don't know. Where can I check it? – Utku Apr 16 '16 at 17:14
  • @Utku System Preferences → Language & Region – grg Apr 16 '16 at 17:15
  • Yep. Region shows Turkey. So this might be the reason? – Utku Apr 16 '16 at 17:17
-2

I had better luck using "string1" & "string2".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .