I recently upgraded to Lion which led me to install a new version of Fuse for the 64bit kernel.

Today I upgraded to 10.7.1 and get the following problem.

When I mount my truecrypt volume the MDS process uses all available memory (It takes 5GB real memory) leaving 3MB of my 8GB in the system. Some procesesses will randomly start using more than 150% cpu and the system becomes extremely unresponsive. (10 seconds before responding to keyboard or mouse clicks.)

If I unmount the truecrypt volume and kill-9 the mds process the computer goes back to normal.

I've tried booting the kernel in 32bit mode with no improvement.

  • I'm not sure how easy it would be since I never used Truecrypt and don't know how to "de-encrypt" a volume (probably just a matter of copying files out of it?), but I suggest you switch to the new, Apple-supported built-in whole disk encryption FileVault offers.
    – zneak
    Aug 29, 2011 at 14:54

2 Answers 2


It is possible that Spotlight is the cause of the heavy RAM usage. You could try removing the truescript volume from Spotlight preferences and see if the heavy RAM use goes away. If it does, you have your answer.

If not, open Console and type mds in the filter blank (top right). That should show all log entries for mds, and there may be a word or two that you recognize.


The problem was a corrupted spotlight folder in the truecrypt volume. I tried disabling spotlight and deleting the index with the mds util but I guess the mds process would crash as soon as the volume was mounted so that didn't have any effect.

The problem was fixed simply by sudo rm .Spotlight-V100

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .