1

I've updated bootcamp to Windows 10 which should support GPT with protective MBR without any hybrid tricks. I have 6 partitions on disk0 so hybrid MBR is also inconsistent with GPT and it's somewhat dangerous.

I've used gdisk to remove hybrid MBR but now Windows can't boot with "No bootable device ..." error on black screen. I've tried to use windows rescue disc and run bcdboot C:\Windows /s C: /f UEFI and bootrec /fixmbr (this one returns an error) but it doesn't help.

What am I missing? Should I put windows BCD to Windows or EFI partition? I use rEFInd as boot manager.

Romans-MacBook-Pro:Microsoft root# diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            120.8 GB   disk0s2
   3:                 Apple_Boot Recovery HD             1.3 GB     disk0s3
   4:       Microsoft Basic Data System                  215.4 GB   disk0s4
   5:       Microsoft Basic Data Data                    608.0 GB   disk0s5
   6:       Microsoft Basic Data Var                     54.7 GB    disk0s6

Romans-MacBook-Pro:Microsoft root# gdisk -l /dev/disk0
GPT fdisk (gdisk) version 1.0.1


Warning: Devices opened with shared lock will not have their
partition table automatically reloaded!
Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present


Found valid GPT with protective MBR; using GPT.
Disk /dev/disk0: 1954210120 sectors, 931.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 059ED97F-5648-C842-89C2-7E8F3FC9388F
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1954210086
Partitions will be aligned on 8-sector boundaries
Total free space is 262445 sectors (128.1 MiB)


Number  Start (sector)    End (sector)  Size       Code  Name
   1              40          409639   200.0 MiB   EF00
   2          409640       236427711   112.5 GiB   AF00
   3       236427712       238966783   1.2 GiB     AB00  Apple
   4       239228928       659873791   200.6 GiB   0700  Windows
   5       659873792      1847439359   566.3 GiB   0700  Data
   6      1847439360      1954209791   50.9 GiB    0700  Var
  • What is the model/year of your Mac? Did you do a clean install or upgrade from a previous version of Windows. If previous, which version. Which version OS X are you running? I also have 3 NTFS partitions on my iMac, but I am still using hybrid MBR/EFI partitioning. The total number of partitions on my iMac is 9. – David Anderson Apr 15 '16 at 14:42
  • Macbook Pro late 2013. Upgraded from Win 7 to Win 10, then tried to remove hybrid MBR. OS X El Capitan. – Poma Apr 15 '16 at 15:22
1

Moved bootloader (EFI folder) to EFI partition and everything started to work properly

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .