0

I receive this error message when trying to run curl from the terminal command line:

/usr/local/bin/curl: line 61: /usr/local/bin/sed: No such file or directory
/usr/local/bin/curl: line 65: /usr/local/bin/sed: No such file or directory
/usr/local/bin/curl: error: `/Users/xxxxx/.libs/curl' does not exist
This script is just a wrapper for curl.

curl used to work on Yosemite but it has been awhile since I used it. Any help in fixing this error would be greatly appreciated.

I tried using the curl provided by AMPPS download and changing my path to hit that curl first. Curl works but then has problems with every sites certs. Tried downloading the cacerts file from http://curl.haxx.se/docs/sslcerts.html and specified the file but still same problems.

I really need curl back in any form. Thank you in advance.

MacBook Pro with Retina display, OS X El Capitan (10.11.4)

0

The errors shown suggest that you installed curl (v7.48.0 or much older) via homebrew or with another custom installer. The system's own original curl (v7.43.0) is located at /usr/bin/. Additionally it seems that curl is not installed as keg-only. This means that the homebrew curl is soft-linked to /usr/local/.

You may either update and repair brew/curl, modify curl.cfg to reflect proper paths or modify your PATH variable.

Or use the full path to the original curl: /usr/bin/curl

  • Thank you put /usr/bin in front of /usr/local/bin in my path fixed it – DallasDawg Apr 15 '16 at 16:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .