1

Even when my viber application is open on a specific discussion, it continues to vibrate on every received message part of the current discussion.

How can I turn off this very annoying feature for Viber discussions ?

or, if not possible,

How can I turn off the whole Viber notifications vibration ?

I currently use an iPhone 5

  • Send feedback to the app maker... They choose it to work that way. – Tyson Apr 14 '16 at 13:46
  • Do you want to turn off vibration on Viber for every message or only when you're in a discussion? – fsb Apr 14 '16 at 14:02
  • 1
    @fbara, I add a precision inside the question – PEC Apr 14 '16 at 14:13
  • Because, well, thats what it does when it receives a notification on silent.. – OzzieSpin Sep 22 '16 at 17:02
2

It looks like the feedback has been acted upon, and it is now possible to turn off vibrations and sounds while you are using the app already. A very welcome change indeed! (Not sure which version it was implemented in) You can do it by going to "More" tab on Viber, and opening Settings -> Notifications, and turn off "In-App vibrations". See the official Viber documentation here. Excerpt:

In-App Vibrate

When this option is enabled, you will receive a vibration for every incoming notification.

| improve this answer | |
1

It's my understanding that you can't turn off specific vibration notifications in Viber; that's just how the application is built. I've seen messages on the Apple discussion boards with people complaining about this from almost 3 years ago.

To turn off all notifications for Viber, go into Settings --> Notifications --> Viber. Switch the Allow notifications to off. This will disable all notifications for Viber at the iPhone level.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .