1

My wife's Mac is acting up and I've been trying to sort it out for a while with no success.

Anytime she opens a new Finder window, tries to upload an image to Facebook, exports an image from Lightroom, or does any other file related task. The system hangs for 1 to 5 minutes before popping up an error that says "There was a problem connecting to the server "Steph's Mac". Everything then proceeds to work normally.

error message

Here's the thing. The computer that is having the problem is called "Steph's Mac". There is no other computer with that name. There never was a server called "Steph's Mac"

Here is what I've tried:

  • Sharing settings: disabling SMB
  • Disabling file sharing completely
  • Finder / Connect to server: clear recent servers...
  • Changed computer name to "Studio Mac" Error window still reads "Steph's Mac"
  • Signed out of iCloud account
  • Sys Prefs / Accounts:
    • Login Items - removed all of them
    • Login Options / Join... / Open Directory Utility... searched mounts. there was none
  • disabled Bluetooth
  • Ran First Aid from Disk Utility on all the drives.

Edit: Added more checks

  • cleared ~/Library/LaunchAgents
  • cleared /Library/LaunchAgents LaunchDaemons & StartupItems
  • cleared ~/Library/Preferences
  • Disabled Dropbox Finder integration
  • Turned Adobe Creative Cloud Sync off

End Edit

I figure somewhere deep in the preferences it's finding something that's telling it to connect to a server. But I can't figure out were.

  • Did you already try to create a second admin user? Logging in as 2nd admin check if the problem persists. If the problem vanishes check the folder /Users/wifes_user_name/Library/LaunchAgents. If the problem still occurs (logged in as 2nd admin) check /Library/LaunchAgents or /Library/LaunchDaemons. – klanomath Apr 14 '16 at 0:32
  • @klanomath. hey, I created second admin account. No problems. checked ~/Library/LaunchAgents, there was only 3 items. moved all 3 to the desktop and left the folder empty. restarted. problem persists. – tyler mackenzie Apr 14 '16 at 1:05
  • Do you have something like DropBox installed? – klanomath Apr 14 '16 at 1:08
  • Just for good measure I tried the same with /Library/LaunchAgents and LaunchDaemons. still nothing. Yes she has Dropbox installed. – tyler mackenzie Apr 14 '16 at 1:16
  • If it doesn't effect a 2nd user it's usually only related to files/settings in the user's user folder/subfolders/preferences and not to system wide daemons/agents – klanomath Apr 14 '16 at 1:31
1

You may be able to hunt down the problem by creating a second admin user.

If the problem vanishes logging in as the second (admin) user, it's probably related to an item/setting in the realm of the first user.

If the problem persists it's probably related to a system-wide setting/start-up item (e.g. a launch daemon/agent).


In the first case you can disable several items (e.g. user related Login Items/StartupItems/LaunchAgents) and check if the problem persists.

A second source of error may be an (old) self-referential link of a local share to the local folder of a cloud storage, file synchronization or personal cloud service (e.g. in Dropbox, iCloud or even some Adobe Online service).

In the second case check the folders /Library/LaunchAgents, /Library/LaunchDaemons or /Library/StartupItems for suspicious plists/files.

  • Created second admin user. This user has no problems so I know it's something in my wife's account. But I've tried disabling all launch Agents and startup items. I've turned off finder integration for dropbox and adobe and signed out of iCloud. How would I go about finding "an old self-referential link" ? – tyler mackenzie Apr 15 '16 at 1:46
  • Checked through files an folders, nothing seemed out of the ordinary. Unlinked dropbox account. rebooted. still no luck. – tyler mackenzie Apr 15 '16 at 2:07
  • Well as I had stated earlier. It was already disabled. I figured I might as well try that too. I'm beginning to think that just creating a new user and migrating all the files is what I'm going to have to do. – tyler mackenzie Apr 15 '16 at 2:24
  • @tylermackenzie Before doing that create a new Preferences (Old) folder in /Users/wifes_user_name/Library/ and move all items in the current ~/Library/Prefs folder to it. Then log-out / log-in or reboot. – klanomath Apr 15 '16 at 2:52
  • Moved all files in ~/Library/Preferences to ~/Library/Preferences OLD. rebooted. still no luck – tyler mackenzie Apr 16 '16 at 17:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .